Installation Issues! Please help!

Hello ArchLabs Community

Just to get it out there, I am trying to switch to Arch for the first time as I really need to extract more performance out of my old laptop. After spending days going through numerous articles / videos / etc I settled on ArchLabs as I loved the installer, the bare nature of the distro and also the out of the box experience.

But, since yesterday, I have tried a million times and failed to install and get it running. Surprisingly, I find no one with similar issues! What’s going on?

In my last attempt, I finally got through the installation when I did not select any additional package, selected only dwm as my wm and just went with the defaults for partitioning etc. But to my amazement, when I tried to log in, it said dwm not found! Like seriously people, what is going on!

It will be highly appreciated if someone helps me out real-time with installing ArchLabs! I am waiting with my installer ready. Please help me out or point me to things I can do to help myself out!

Thanks for your time.

Regards
R

Hi rkt,
try another install with i3 and after install use the library from @nwg, really great for tiling


about dwm, you can so install after the yaxwm from @natemaia i use it is really good and i think it will be good to have in choice for installation., it is like dwm with some features.

https://bitbucket.org/natemaia/

About your issue, you can open a terminal by ctrl+alt+F2 and then install dwm with baph tools (in default) from AUR.

1 Like

I cannot even complete the installation process most of the times. Currently I am trying again with Awesome.

I remember having issues with auto-partitioning selected. No idea if it still happens, as last several times I partitioned manually.

It would be easier to help if I knew what kind of failure you’re running into.

I have tried both manual and auto. Sometimes one works for me, sometimes the other works! I really don’t know what is going on or where to look!

I do see that some downloads fail due maximum file size exceeded from SourceForge. Also the 3rd step where the post-transaction hook creates temporary directories gives failed error.

Most of the times it just said no error messages!

I am done with my current install with awesome. It says finished. Hopefully it’ll work this time!

Try swapping the sources around in /etc/pacman.conf to use something other than SourceForge. That won’t fail install though, it will fallback to the others on its own.

I don’t know what was going on, but I think I finally had a successful install. Tell me if this is how it supposed to look!

Also is there a way to install ArchLabs on top of a bare bones Arch install? I will like to use the setup you guys have made and get back to working on my projects asap (have pending work :sob:)

1 Like

You can install the same packages and configs yea, all our stuff is available.

Getting ~300-315M ram usage in idle with just xterm+htop. Is this the lowest we can go?

You have 4G, why is it an issue? If you test on a machine with more limited resources it would be lower, try a VM with 256M and it’ll be much lower. It’ll gobble more if you have enough rather than swap to disk all the time.

Can you tell me how or redirect me to some reading material on how I can get the packages, which packages to get and how to setup?

I used ubuntu 16 + gnome for a long time. It consumed ~1-1.3G! So much happier now :slightly_smiling_face:

The installer source is where I’d direct you. I don’t know of any guides as there’s not much purpose, we already use plain arch as a base so it’s all the same aside from a few configs it’s not like manjaro where they have separate repos.

As far as packages go, almost all of ours are the skel configs. /etc/skel gets copied over new users home directory. The package list varies depending on what sessions are being installed.

Once I exit out of awesome, I get a bunch of errors. And I noticed a lot of things were not working inside awesome too, like the clock and other icons on the top right.

I was checking out the repo (the bitbucket one) yesterday only. I will dive deep once again tonight and try to figure out on my own. Thanks :+1:t2:

What s your hardware & gpu, might help other people in order to help you out with the install.

Hope that you ll get it resolved quickly enough @rkt

Looks like one of the keybindings isn’t recognised and a couple of programs have child processes that are exiting successfully. Not big deals IMO.

I can’t remember if ArchLabs logs X errors, is there a file at ~/.xsession-errors that you could post the content of here? If not then launch X manually with

startx 2>~/.xsession-errors

We don’t redirect the X output, generally the Xorg logs can be found in ~/.local/share/xorg/Xorg.0.log where 0 is the display. Arch defaults to rootless xorg I believe but if you disable I think they’re in /var/log/xorg.

1 Like