Installation error

I am really interested to tryout archlabs linux
Now I am using arcolinux openbox it’s a bit heavy on ram usage so I thought I should install archlabs because archlabs openbox is looking gorgeous and lightweight so tried to install it
But the first problem was the wifi connection or wired connection is not working I can only ping a certain sites
So tried to fox it by helps from your forum posts I tried variety of methods (changed the chk_connect line,change bios date etc…) but finally I thought it might a issue with my isp so tried vpn and it worked.
After successful connection I tried to install the os
With openbox and dwm it tried so many times with and without additional apps and saw installation guides from YouTube and many other methods from this forum but Everytime I get the same error

('installation error Pacman -S openbox …etc
Error In this stage is …
To fix manually ")

I am really sorry I don’t remember the error exactly and sorry for the long post
I really like the support in this forum you guys are awesome hope I will be able to install the distro

Update (pacman -Syu) before you run the installer command. :smiley:

1 Like

Thanks for the quick reply :blush::grin:
Just -Syu
Or force update (-Syy)
Anyway I will try to run update (-Syu) before
Archlabs-installer command
I think I have to connect to WiFi before installer command by nmtui and update the system
Thanks for the support ,:+1:

-Syu should be sufficient.

Note that an -Syu is rather large for a USB install. At least I got an error with it. pacman -Sy archlabs-installer is sufficient but then also take note that the installer executable name is then changed to just installer. I also had to nano /usr/bin/installer and remove the s from xorg-font-utils. Everything worked like a charm after that


thank you all for the support
i did install archlabs and just like i expected its a awesome distro
the installation error is gone by doing sudo pacman -Sy archlabs-installer
at first try, I selected the first option of installer rather than the install from iso
the downloading from archlinux repository did gave me about 3MB but when downloading from archlabs repository the speed was like so so slow just 8kbps i tried different methods to fix it but didn’t worked for me
so i choose install from iso it is successful and faster

I have such a problem during installation. What am I doing wrong? Sorry for my english

Update the installer first.

additional thread about updating installer

After the update, the command will be:


It’s worked. thanks

1 Like

Hello. Another error today

Try this…

pacman -S archlabs-keyring
pacman-key --populate archlinux
pacman -Syy archlabs-installer


Good call, might be usefull to others also @Beast

Hopefully man, I’ve ran into a similar issue when installing on my cousin’s laptop, but it wasn’t Nate’s pgp, it was from an Arch developer.

Hope this helps @ElHipo and others too.

1 Like

It may sound strange, but this command worked:

timedatectl set-time “2020-10-28 HH:mm:ss”

1 Like

That s some good news @ElHipo

1 Like

PGP is very picky when it comes to time synchronization so I’m not too surprised.

1 Like

That’s the beauty of Linux man :upside_down_face:

I’m glad you got it @ElHipo. Cheers! :beers: