ArchLabs Linux

Installation error "Arguments list too long"

Hi everyone.

Description

I tried ArchLabs in a VM a couple of times, really liked it and decided to install on my laptop for real this time. Took current latest image, 2019.01.20.

And it failed with the following:

/usr/bin/archlabs-installer: line 2619: usr/bin/dialog: Argument list too long
About the error

I googled a little, found a stack overflow question.

  1. Not sure I can really break this dialog command into smaller ones (like rm [a-l]*; rm [m-z]*
  2. One answer there advises to run ulimit -s 65536. it didn’t help me. How much should the number be? And can it help at all?
  3. Another answer gives a link to Linux Journal article from 2002. There’s a completely different advice: patch the kernel, recompile and reboot. Is it even possible with a live environment? I can’t even run pacman -Syu.
Questions

So I have some questions.

  • How do I work around this problem?
  • The problem looks independent from hardware, so why do I face it on real hardware and don’t face inside a VM?

Likely just shitty scripting on my part and one of the dialog functions has a bad call.

At what point during install do you get this?

Sorry to be that guy but the installer has had so much change over the last year that it’s tough to resolve this now. The upside is that it shouldn’t exist anymore and was an error with that release. If you’re adamant about installing with that iso I could find it and post an edit here or I can pm you a link to a more recent beta iso, choice is yours.

1 Like

@natemaia

At what point during install do you get this?

I launch the installer, choose all the configurations I want to have and hit “Start the installation”. Then a looooooong list of files (or folders, not sure at the moment) appears on the screen (I presume they are copied from the USB drive to my HDD). And then I get this message, the installation doesn’t get to the point where pacman does it’s share.

the installer has had so much change over the last year

Yeah, I know, that there were a ton of updates to almost everything :slight_smile: At this point I wanted to install the existing version, see how it goes and probably install a new version on top of it when it comes out.

or I can pm you a link to a more recent beta iso

If It’s possible to try out current beta, I’d be happy!

Sad story: tried the image you shared with me, and the installation failed anyway.

Command: pacman -S <…> --noconfirm

Error: warning: bluez-libs-5.51-2 is up to date – skipping
error: target not found: urxvt-pearls
warning: archlabs-keyring-2019.10.06-1 is up to date – skipping

Errors at this stage are fatal, the install cannot continue

Got the same kind of errors installing in a VM (can’t recall now if it was with the same set of packages).

UPD

Removed rxvt from selected packages, everything installed just fine. Thanks, @natemaia!

I’m confused by this, urxvt-pearls in in the arch repos. Gonna have to test this out, possibly remove it as an addition for rxvt

I think it is just a typo. Should be perls rather than pearls.

1 Like

Wow! Can’t believe I didn’t catch that even when checking the repos, thank you!