I3wm is getting installed instead of i3-gaps with zero configuration

I recently found out about ArchLabs so the first thing I did is to download the iso and install it in a virtual machine to check it out. I installed the i3-gaps version and I loved it. So naturally I decided to make the switch to main machine as well. I went through the installation process and selected i3-gaps and couple of other packages like firefox, libre-office, thunar, urxvt, fonts awesome, etc. with the space bar and did the installation. After the first reboot I see the lightDM as it supposed to be but as soon as I login it asks to me make my config file and select my mod button which is the first thing to do in i3wm. This didn’t happen to me when I tried it on VM and now I am typing this post from a non-configured i3wm instead of a configured sleek looking i3-gaps.

Would really appreciate some help regarding this. I installation one more time to make sure i didn’t select anything wrong but I still ended up with i3wm instead of i3-gaps.

That’s very odd, I just installed yesterday again and had no issue, i3 is my main desktop…I can share my config if need be… you can just copy and paste…it’s very close to default al config.

I think I’m doing something wrong with the boot mode. When i open the boot options and select archlabs it doesn’t open the default Arch looking like option with the arch logo and all instead its just plain black screen with options here’s a picture: http://imgur.com/a/qVNsdXn

Thank you but unfortunately i have reverted back to manjaro kde for now. I don’t want to spend too much of my time configuring i3 at least for the time being.

I have never encountered that behavior before…maybe something to do with the UEFI system. Just an FYI, manjaro has a decent i3 spin also, if you haven’t tried it.

If it is the UEFI then i messed up because i don’t know anything about it.
Yes, i know. I was using manjaro i3 before jumping to ArchLabs.

Hey, I finally fixed it! My mistake was that I wasn’t formatting the EFI partition and was using the one i had with manjaro… I used cfdisk to delete the whole drive, create a new partition and then use the auto partition. I freaking can’t believe it I am an idiot.
Thank you for your help man. Appreciate it a lot.

1 Like

Congrats, top job @aaronryder

No worries, I’m sure we have all done similar or dumber in our Linux history…I know I have.


You can say that again @TimApple. Sometimes , we need to be humbled so as to also learn from the experience.

1 Like