I3wm (i3-gaps) && polybar (with gaps)


#1

Hi guys, let me explain.
So I would like to use gaps also with my polybar when using its offset option but it won’t let me do it, I have added this in the polybar master config:

override-redirect = true
This allows me to use offset-x and offset-y options, and that’s nice (it does the job without having to set the borders transparent) but if I do that the windows lose their gaps and recover the bar…
If I set the “override-redirect” to false, windows respect the bar and the gaps is here again but the offset is lost.
I don’t really want to sacrifice its borders (eh I like them) and make it transparent so I could do “as if”.
Is there a trick or is this a non resolved i3wm incompatibility ?
Thank you by advance.


#2

Hi @k43r17h, here is a part where he talks about i3 and polybar:

Have you also tried with the .config/i3/config file?


#3

In fact I have already tested the restack option, and that causes the windows to be behind the bar. Without that option, it’s inverted, the bar is behind the windows…
(:neutral_face:)
For the i3 config file, I didn’t know there was something in here which (that?) can help.


#4

I’ve been trying to do something similar to the configurations of @LionessAlana, to prove what you said, but I’ve not succeeded. Look at the link to the screenshot, I think you want to do something similar. Sorry if I have not been of great help @k43r17h .


#5

Eh @Negata don’t be sorry for that and yes this is indeed what I try to realize !
Can I ask you if it’s possible to share the config ?


#6

I am glad to know that this is what you were looking for, my first language is not English and sometimes it is difficult.

Regarding the configuration, I’m using Slim-polybar. If you ask @LionessAlana, she can guide you better than me to that particular configuration.


#7

Thx that’s what i will do, good night


#8

You’re welcome, and do not hesitate to ask anything. They are a great team. And this forum is a good place to learn, answer questions and be inspired.

Good Night

Salud


#9

@k43r17h and @Negata, my config is included in my signature or can be found here. The most recent theme is listed as Vapor, so you’ll find my most recent polybar config there.

It’s worth noting that I recently switched to dwm instead of i3, and I’m using the dwm bar and not polybar, but I’ll help out however I can!


#10

@LionessAlana
Thank you I’ll check that, it will give me work for my evening