ArchLabs Linux

I3-gaps window freeze

When I switch between workspaces, an “image” of the previous workspace is displayed instead of the program running in that workspace.
Also when this happens its impossible to exit out of the program with i3 key bindings, i have to do killall -9.
I’ve attached a video, 0 to 20secs is me launching spotify and showing all three workspaces, about 1min10sec is when i start switching between workspaces and when the bug appears. Workspace 3 is suppose to be spotify but instead it shows an “image” of which ever workspace i was on before.

Some additional information

  • This is a fresh install, running on xps15-9570
  • Time it takes for this bug to appear is random
  • Most common on steam and spotify(what do these apps have in common)?

They are both streaming services aren’t they - games and music? I don’t use either.

What are the system specs - particularly video; are you just locking up the system running both at the same time?

Does your system freeze when you aren’t running either of them?
Does your system freeze when you are only running one of them?

Intel Core i7-8750H
8GB DDR4
NVIDIA GeForce GTX 1050Ti
I dont think specs are the issue

I had a very similar issue with specific apps running i3. Disabling compton helped but did not entirely fix the issue. No issue anymore since switching to dwm. Not helping much, probably, just to let you know.

Oh and funny thing, I am running a XPS 9560. It does have different hardware, though.

Try setting problematic applications to floating. It’s been a long time since I’ve used i3 so I’m not entirely sure, as @xsme said it could also be compton causing it, try different settings and see if it keeps happening.

Are you using the nvidia driver or nouveau?

Honestly it kinda looks like i3 crashing but I’m not certain.

huh setting it to float seem to have fixed the problem for now, why is that?
nvm its back : (

Also im using nvidia drivers