I3 and VirtualBox?

Hi
using xprop I identified the correct strings, but the following doesnt work in my config

assign [class="VirtualBox Manager"] $ws8
assign [class="VirtualBox Machine"] $ws9

However, the following line does:

assign [class=(?i)virtualbox*] $ws9

Does anyone use VB with i3 and/or can explain to me why and how to get the VB managerand machine to appear on different workspace?, please?

If I open both Manger and then Machine on the same workspace, I can use [S]+Shift + 3 (for example) to move the VB Manager to WS3, but not to move the VB Machine window (it does nothing)

1 Like

I don’t use i3. Try the followings, don’t know which one would work.

assign [class="VirtualBox\ Manager$"] $ws8

assign [class="^VirtualBox Manager$"] $ws8

assign [class="^VirtualBox\ Manager$"] $ws8

Thanks @chroot
Actually, I had made a typo (no capital ‘B’ in Box) and the following works:

assign [class="VirtualBox Manager"] $ws8

But none of the following then work when opening a VM from the manager, the VM opens in WS8 as well

assign [class="VirtualBox Machine"] $ws9

assign [class="VirtualBox\ Machine$"] $ws9

assign [class="^VirtualBox Machine$"] $ws9

assign [class="^VirtualBox\ Machine$"] $ws9

However, I can then use [S]+Shift + 9 to move the VB Manager to WS9

Also, I worked out that I could also use [S]+Shift + 9 to move the VB Machine to WS9, by first uncapturing my keyboard in the VM host (by pressing the Host key (the default Right Ctrl in my case)

I still have no idea why I cant make he Virtual Machine open in another WS to the Virtual Manager, but the above work around will do.

1 Like
assign [class="VirtualBox Manager"] $ws8
for_window [class="VirtualBox Machine"] move container to workspace $ws9

The above works!

1 Like

Glad that you fixed it @leigh

1 Like