I/O error during installation

I just downloaded the latest archlinux version from sourceforge. I have 0 problems during the installation, very clear and simple, but when I run the installation, I get an I/O error.

Here’s the traceback

  • I have selected both the linux and linux-lts kernels.
  • I burned the image on my usb with dd. sudo dd if=archlabs_date.iso of=/dev/sdb bs=4M
  • The selected bootloader is grub
I really appreciate the help if anyone could provide some. :slightly_smiling_face:

Checking ISO Validity:
https://archlabslinux.com/get-archlabs-2/

1 Like

Yep , iso might be corrupted, a good start as well. Happened to me in the past.

Good call @ector

1 Like

I’ll try that. Sounds promising!

1 Like

Hopefully it will fix the issue @Levasseur-Sp

1 Like

If using dd, try burning it like so…

dd bs=4M if=path/to/archlinux.iso of=/dev/sdb status=progress oflag=sync

https://wiki.archlinux.org/index.php/USB_flash_installation_media

1 Like

Now it’s a different error and I assume it’s on the hardware side.

If I understand correctly, it means that some blocks on my drive are corrupted or something, right?

What are you computer system specifications?

Are you dual/multi booting?

Last time i had i/o erros like this my hard drive was gone. But that doesnt mean yours is just yet.

Do you boot into another system on the same drive that is ok?

I am single booting on my ADATA SU800 SSD.

I don’t mind wiping my drive everytime I switch distros because I have my laptop but that’s beside the point.

Ok so maybe try this to the disk before you try to install again.

# shred -vn1 /dev/sda

# sgdisk --zap-all /dev/sda

But maybe better to check bad sectors on the disk first.

https://www.tecmint.com/check-linux-hard-disk-bad-sectors-bad-blocks/

So to be sure, shred will overwrite every file contained in the drive and sgdisk will wipe them?

I just read the man pages

pretty much you will have a blank drive. Please check for bad sectors first though.

https://www.tecmint.com/check-linux-hard-disk-bad-sectors-bad-blocks/

I’ll do that beforehand then! A 1TB drive is going to take a while! :joy:

That it will. Sorry if you are using the archlabs live session maybe use badblocks

https://wiki.archlinux.org/index.php/badblocks

Quicker alternative for SSDs:

blkdiscard /dev/sdX

Might even be the usb you are using is no good any longer? have you tried another usb drive?

Hold on a minute, those are SQUASHFS errors so it’s the USB stick (or the image itself) that’s corrupted.

3 Likes

Yes,exact and also the previous errors of the posted image.
Cheers

That’s weird because the checksums were correct. :joy:
So I just have to re-dd another download of the image and pray?

Rinse and repeat until it works I guess

Try another USB and report back?

2 Likes