I need help installing archlabs on a new laptop AGAIN(((

Hi everyone again!
I’m trying to install archlabs on a laptop with windows 10.
In the latest release archlabs-2018-03, changed the installer…
I divided the disk into partitions /swap /root /home
Disk partition remaining /boot/uefi it already exists for windows…

Guys, lead me through the installation process, I’m afraid to spoil everything…
Previously, the installation was simpler, more intuitive

[Solved] I wrote the image through etcher and dd (terminal)
Loading process:

ArchLabs x86_64
UEFI Shell x86_64 v1
UEFI Shell x86_64 v2
EFI Default Loader
Reboot Into Firmware Interface

I choose the first item, and it seems like the download begins…
After a while, it stops, and nothing happens next…
Graphic installer does not start…
Strange, I already have archlabs on an old laptop, and I had no problems …
I suspect that this is the case in UEFI
I was trying to run the installer manjaro, and it works
Guys! Help me please…

Have you disabled secure boot?

Yes, turned it off. I tried:
Secure Boot Mode - on, off
Fast boot - on, off
Boot mode select - UEFI, UEFI with CSM

Can I get you to try and use the Calamares installer from 2017.10 release. Let me know if this works or not.

I’m going to try now. Give a link to download, please


Thank you.
@Dobbie03 can i install new theme “Sandy”, saw in your messages. I really liked it

Of course :slight_smile: Wouldn’t have shared it if I didn’t want others to use it :smiley:

Does the majaro installer use watchdog?

Maybe disable that on boot with “nowatchdog” - based on ector’s soulution to turn it off.

I tried to run 2017.10 release … The same story…
The image was recorded using dd

Maybe disable that on boot with “nowatchdog”

I do not know how to do this…

Boot the live medium
When the grub menu comes up press “e”

That brings up the grub configuration

On the line that starts with “linux” at the end add “nowatchdog”

At the bottom of the screen there should be instructions about which key to hit to continue with booting.

the temporarily add section for live boot


Archlabs, Antergos - not loaded with usb
Manjaro - loaded

Menu grub does not appear
Only this appears:

That’s new to me, not sure what to do there if you want to add kernel parameters.

^^ That’s systemd-boot and the method is the same as with GRUB.

Try adding nomodeset, maybe add nouveau.modeset=0 as well if you have an NVIDIA card or i915.modeset=0 if you have an Intel card (add both for an Optimus system).


Ok, I’ll try now

Thank you very much, it worked!

nomodeset nouveau.modeset=0 i915.modeset=1 radeon.modeset=0

Some parameters were taken from the Manjaro.iso

1 Like

^ That’s weird, I thought the radeon driver required KMS :confused:

Which drivers are loaded for the desktop?

lspci -k | grep -A2 '\''[030[02]\]'
1 Like

Could it be that he has an AMD board and not an Intel board?:thinking: