I don't have any i3 session in lightdm

I don’t have any i3 session in lightdm.
How can i create one?

Was an i3.desktop file created in /usr/share/xsessions ?

If it doesn’t exist, you will have to create an i3.desktop file. You can use the openbox.desktop as a template.

Once created, there should be an option to log into i3 from the lightdm list.


I am fairly certain that the Arch distibution of i3 includes an xsession file, if you don’t have the session listed in lightdm then you probably don’t have it installed. Did you install the package i3wm or i3-gaps?