I cant run thunar

thunar: Failed to initialize Xfconf: Error spawning command line ?dbus-launch --autolaunch=22bd388f3d974e259aab921469b64b2d --binary-syntax --close-stderr?: Child process exited with code 1

No protocol specified
Unable to init server: Could not connect: Connection refused

(thunar:3057): Gtk-WARNING **: 22:18:19.302: cannot open display: :0

this message appear when i want to run thunar in root

can a person help me ?
in french if you can

i use pinguin i dont know if its useful

What Thunar version do you use @123yuyu .On my end I wouldn t use Thunar as root.

Edit; Your English s pretty good to me @123yuyu by the way.

Also have a look at this link;

https://forum.xfce.org/viewtopic.php?id=13064

What’s “pinguin”?

How do you try to run Thunar as root? From the terminal or as a right click “open as root” from Thunar itself?

Edit - try running thunar with:

pkexec thunar

before installing dbus-x11.

Make sure dbus-x11 is installed.

Thunar does not open as root

1 Like

In a terminal try:

pkexec thunar

I installed thunar, and get the same error message with “sudo thunar” in a terminal, but thunar still launches. Thunar also launched with “pkexec thunar”.

Try using pkexec before installing dbus-x11.

2 Likes

Guess that pkexec replaced gksudo a while back.

1 Like

sudo thunar works fine here and always has. pkexec thunar also works perfectly as well.

I’m assuming that @123yuyu is trying to use the right click open as root in Thunar itself.

2 Likes

Might be because that

dbus-x11

is not installed yet.

1 Like

I use thunar 4.16.8

I installed that

I have a chromebook …

pkexec thunar
thunar: Failed to initialize Xfconf: Error spawning command line ?dbus-launch --autolaunch=22bd388f3d974e259aab921469b64b2d --binary-syntax --close-stderr?: Child process exited with code 1

No protocol specified
Unable to init server: Could not connect: Connection refused

(thunar:1137): Gtk-WARNING **: 07:10:21.652: cannot open display: :0
``
the same

a version of linux i thinks

Umm yes it’s based on Gentoo. But this isn’t an Arch base. So is it Chrome OS or is it something else you have installed?

You are not supposed to run thunar as “root”. If you have to, open a terminal,

$xhost

$sudo su -

#export DISPLAY=:0 

#thunar

when i do xhost

No protocol specified
xhost:  unable to open display ":0"

No its chrome os

i thinks its an error with the display