I can't login to display manager gdm


#1

how to switch to default gdm manually by code?
Because i has been make mistake delete gdm and gdm-session, and now im stuck on blank screen, Sorry, my English is bad🙏


#2

Your English seems good to me.

Have a look at this link here, hope that it can help you out:

https://forum.archlabslinux.com/search?q=%20can%E2%80%99t%20login%20to%20display%20manager


#3

Can you post which command(s) you used to do this?

Have you tried re-installing the package?

pacman -Syu gdm

Try using <Ctrl>+<Alt>+F2 to get to a spare console screen from which you can run the command.


#4

@Sansanmosh I have pm you.


#5

@sevenday sorry for duplicate content :pray:


#6

@altman thanks bro i wil try it…


#7

i record my problem to video, my problem after booting can’t load to gdm stuck blank screen


#8

https://streamable.com/iuo03 (link video)


#9

i dont get the spare console i`m just still stuck on black screen


#10

Here are the steps I would take.

  1. When the screen is blank like that, go to a virtual term (Control Alt F2, for example)
    Login as root

  2. Check to see if GDM is actually running: ps ax | grep gdm (I am guessing on the gdm part as its been a very long time sine I ran Gnome)

  3. If it does not show running, you could try enabling the service: systemctl enable gdm

  4. If the service is running, skip to step 6

  5. If you enabled the service from step 3, start the service: systemctl start gdm

  6. Reflecting on an above post, remove gdm: pacman -R gdm

  7. Then reinstall gdm: pacman -S gdm

  8. Enable the service: systemctl enable gdm

  9. Reboot

  10. Report back your results.


#11

OK, you will have to load the “live” ISO image and chroot in.

Mount your main system partition first:

mount /dev/sdXY /mnt

Replace X & Y with the drive letter and partition number for your root partition.

Then chroot in:

arch-chroot /mnt

From there you can pacman -Syu gdm to try re-installing the display manager.

Once that’s done, exit & reboot:

exit
reboot

hth


#12

in my problem i can`t go to a virtual term ( ctrl + alt + F2 ) just stuck blank bro


#13

i will try it i hope it works :pray:


#14

after command (arch-chroot) /mnt i can’t install pacman or ping google etc


#15

Is the installation spread over several partitions? If so then you need to mount the other partitions (under /mnt) before chrooting in.

If not then I suppose you could try calling the full path (/usr/bin/pacman -Syu gdm) but I think arch-chroot sources /etc/profile so PATH should be set.

We still don’t know what you did to “delete gdm and gdm-session”, can you tell us what command(s) you used?


#16

even im delete gdm and gdm session im forget to set into lightdm , i`m delete using pacli force remove package



#17

Finnaly now i can login using console with shortcut alt + f2 even sytem loading before load to gdm then install gdm and enable, thanks to all :pray:


#18

Glad it worked finally !


#19

That calls pacman -Rdd[1], which is really silly.

Don’t use that option, ever.

The ArchWiki even has a warning to that effect:

https://wiki.archlinux.org/index.php/Pacman#Removing_packages

With a link to:

https://wiki.archlinux.org/index.php/System_maintenance#Avoid_certain_pacman_commands

[1] https://github.com/Manjaro-Pek/pacli/blob/master/pacli#L491