ArchLabs Linux

Http server doesn't seem to support byte ranges. cannot resume

Hi there, my son’s archlabs-laptop isn’t updated as frequently as mine. And when we update his laptop with pacman -Syu we occasionally run into errors.

Last time we got the following error message:

http server doesn't seem to support byte ranges. cannot resume
pacman -Syu --ignore archlabs-icons

helped circumvent the problem. Afterwards the

pacman -Syu

worked, so the issue is solved. However I wanted to know what this is about, googled a bit and google is pointing to a curl-related protocol error.

Obviously the sourceforge.net and bitbucket.org repos of archlabs couldn’t deliver the pkg-files to my client.

Does anybody know more?

Interesting, I’m not entirely sure what happened but my best guess is due to older libcurl version than what the packages were built against possibly including metadata that older versions don’t support or know about.

Why this only happened with the icons package is more interesting still.

I assume archlabs-icons was the only package hosted at sourceforge.net and bitbucket.org. I’m going to do more reading, especially regarding the update procedures.

PS: libcurl isn’t mentioned in /var/log/pacman.log but a whole bunch of other libs