HP ProBook 470 G5

#1

Hi Archlabbers!

I just have a quick question. Anyone managed to install Archlabs on a HP ProBook 470 G5 with dual graphic card (intel + Nvidia) https://www.dustinhome.se/product/5011041769/probook-470-g5?ssel=false&_ga=2.148744895.924971641.1552773281-683982290.1552773281

Womp

2 Likes

#2

No, I have never. However, dual graphics cards used to be a huge hassle if you want them to be energy efficient. If you want to set it up, there is something called bumblebee. I would recommend you to go to a store and try it yourself. That is how I tested if my laptop works with linux. Also hp, btw, but only intel graphics.

0 Likes

#3

I havenáş— decided yet because I have to be able to disable secure boot first. It seems i have to be lucky even to do that!! Windows 10! I really dont like it! (I am not allowed to erase it unfortunately!) 500 GB SSD and 400 GB free and Windows only allow shrinking by 50 GB!! Microsoft tries desperately to keep the monopoly.

Womp

1 Like

#4

Well , I might install it without the nVidia driver, some had issues with nVidia on Linux , since it s a dual graphics lappy.

1 Like

#5

I have an hp envy with dual card and I use the free intel-nouveau driver
I don’t play anything, if you want to use the owner drivers I can’t help you

[don@don-pc ~]$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x90 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 1 name:Intel
Provider 1: id: 0x62 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 1 associated providers: 1 name:nouveau
[don@don-pc ~]$

for use prime
https://wiki.archlinux.org/index.php/PRIME

1 Like

#6

Thanks for support Guys!!
I play only old games like Wolf3d so …
Haven´t decided what to do yet. If it´s worth the effort.
I get back here and report later!

WOmp

0 Likes

#7

Cool !

1 Like

#8

Here is a first preliminary report with questions.
Managed to disable secure boot and was able to install. Can not get into Archlabs though! I used Windows boot partition and I did not format the boot partition maybe I should have created a new one?

Womp

1 Like

#9

I don’t know what the new efi hp bios are.
I also I installed with the secure boot disabled, but it seems that if now you can also install in UEFI.
mine I have to press esc f9 to start the linux distro, but I have installed on external ssd.
I happened to use the efi of windows but at the first update of the kernel, the distro was no longer started.
However you wait for the more experienced ones like @natemaia or @head etc etc, they will be able to advise you better.

Edit
it seems to me that the forum has some connection problems, does it also happen to you?

0 Likes

#10

Can we please see the output of this command from Windows:

bcdedit

Or if you have a live GNU/Linux distribution available then please post

efibootmgr -v

Many UEFI implementations are completely broken and will only boot Windows’ UEFI loader, unfortunately.

0 Likes

#11

I tried to install a second time (reformatting and so on). Now I got an installation error. /usr/bin/mkinitcpio: line 261: /etc/mkinitcpio.d/linux-zen.preset: No such file or directory. I did one thing different from last time. I tried to install refind enstead of grub.
After reboot I got grub but no archlabs, thrown to a shell.

C:\WINDOWS\system32>bcdedit

Windows Boot Manager

identifier {bootmgr}
device partition=\Device\HarddiskVolume1
path \EFI\Microsoft\Boot\bootmgfw.efi
description Windows Boot Manager
locale sv-SE
inherit {globalsettings}
isolatedcontext Yes
default {current}
resumeobject {204e47ae-9cb3-11e8-987a-d4258b4bae19}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Windows Boot Loader

identifier {current}
device partition=C:
path \WINDOWS\system32\winload.efi
description Windows 10
locale sv-SE
inherit {bootloadersettings}
recoverysequence {b78f7a26-9cb7-11e8-9287-85851ec3c0b3}
displaymessageoverride Recovery
recoveryenabled Yes
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \WINDOWS
resumeobject {204e47ae-9cb3-11e8-987a-d4258b4bae19}
nx OptIn
bootmenupolicy Standard

Womp

0 Likes

#12

Which shell? What does the prompt say?

The bcdedit output doesn’t show any GNU/Linux UEFI loaders, did you boot the ArchLabs installer in UEFI mode?

0 Likes

#13

Yes that was the only option.

I got thrown into rootfs emergency shell.

Womp

0 Likes

#14

What was the error printed before it throws you to the emergency shell?

Did it fail to find the root partition?

0 Likes

#15

Well I tried again and now I got further. The problem seems to be the boot partition. I use the same as Windows now and that doesnt seem to work. /boot failed to mount. Should I create a second boot partition in vfat or how should I do this?

Womp

0 Likes

#16

Sharing the EFI system partition between Windows and ArchLabs should be fine.

Is /boot listed in /etc/fstab?

If you post the actual error messages rather than your interpretation of them then I will find it much easier to help you.

0 Likes

#17

I am sorry for confusing messages. /boot is present in /etc/fstab.

0 Likes

#18

It’s fine, no need to apologise :slight_smile:

Can you see /boot in the output of findmnt? (No need to post the output, just check if it’s listed.)

What actually happens when you try to boot ArchLabs?

1 Like

#19

findmnt shows /boot. I did a reboot into Windows and an automatic repair started and then I tried to get back to archlabs and I got it started!!
Wifi works (AC-8265) iwlwifi out of the box but I have no sound (Intel Corporation Sunrise Point-LP HD Audio (rev 21) (prog-if 80). Nouveau and i915 loaded. Kernel 4.19.29-1-lts.
Never heard of that audio-card before.

WOmp

0 Likes

#20

it should be
snd_hda_intel

0 Likes