How to start at boot

#25

So, on your first attempt to install, you installed lightdm but only booted to the console? And with this attempt you’re getting dbus errors?

Sounds like you have a damaged installation media. I would download the recent iso again and make sure to run the checksum - there are instructions for that on the download page before you click on the download link.

Recreate your install media and try another clean install - but only select one window manager (or desktop environment) and no login manager. There may be something broken with lightdm.

Hopefully you will then boot to the console and use startx to get to an xsession. If it falls, post any error messages.

Once you get an X-session up and running, it will be smoother sailing to add more window managers etc…

1 Like
#26

Also, what method did you use to create the original installation media?

#27

I installed that none of that worked. here’s tty1 screen.

#28

Ivory downloaded the media yes I’ve made a new startup disk yes. And but I was wondering did you say not put grub on here? Cuz I look up on their thinking actually it works and how am I supposed to boot into other systems if I don’t have grub? I’ve always depended on grub for that is it grub that is causing this mess I’m going to just try and restart it again for the 18th time now and only do one desktop environment one window manager and no grub and see what happens I’m not expecting anything

#30

I used dd on the cl the first time. Rufus on Windows for the current one. Rufus has always worked well if you have to use windows.

#31

If you have downloaded the the iso (again, replacing the one you originally downloaded) and you installed correctly (without skipping any steps and did each step properly) and you still get the errors you are seeing, then one has to assume there is something up with the hardware that ArchLabs does not understand or like.

Unfortunately, there are too many variables that we can’t see and have to take your word on it. Assuming that there isn’t anything that Arch Labs does not understand about your hardware, then the issue has to come down to how you installed it.

At this point, I recommend that you take a time out on installing and review several videos that are mentioned here on the forum. You just might find something that you may have overlooked.

You can find a few YouTube vids within this thread:

#32

typo Ivory should be I’ve. lol.

#33

and no grub

Do not do that - install grub.

No, you need to install grub to boot.

It’s the login manager - lightdm, lxdm are common ones - that you can avoid for now. Those run near the end of the boot process so that you can select a user and a window manager to log into an Xsession.

If you’re boot process is hanging at the login manager stage it will be more difficult to help you fix your system in a forum format. If you can get to a console, it will be a lot easier because you can use the command line tools to fix the system.

1 Like
#34

Always the same thumb drive; how old is it? May be time for a new one.

#35

I’m curious - in your 2nd screen-shot of tty1, were you at least able to do a Control Alt F2 to get to tty2 and try a manual login as root?

Looking at your 2nd screen shot, this is starting to look like an overall video/X issue. X looks like it could be running since tty1 appears to be “hung” - this more often than not, could be related to your video card/drivers (especially if it is Nvidia)

If you are able to get to tty2 and login as root - disable lightdm so that you are back to getting a simple console for tty1.

Then start working on the video driver issues with X. I don’t use Nvidia so I can’t help however, I think there are a few threads here that show some settings that some folks used to get X up and running.

Keep in mind that this is an assumption that it comes down to your Nvidia card and installed drivers.

3 Likes
#36

^ this

@davi - is that error message immediate or near the end of the boot process?

#37

Also @Davi have you looked at wikis and forum posts elsewhere concerning this issue?

What we’ve said here isn’t anything you could pick up quicker from the Arch or even Ubuntu wiki, or the Arch bbs and elsewhere.

I tried Arch soon after trying Mint 9 and didn’t have much fun. The wiki really helped but it was such a culture shock from the easiness (in comparison) of Mint that it took me ages to understand stuff. Even now, years later, I’m nowhere near as good as a few of the people on this forum (for instance I missed telling you to ctrl+alt+F2 to get to a different tty to log in as root and systemctl disable lightdm.service!)

However, you aren’t giving us the full information that any other forum asks about your system. All we know is you have 2 laptops, one i3 and one i7. We don’t know the exact steps you’ve taken during install. What media have you tried putting the iso on to? Have you checked the iso for issues and md5sum?

If you can give us as much information as has been asked then it would be really much much easier to help you, and you might not feel so upset with AL.

3 Likes
#38

@DatNobleSavage , your last 2 paragraphs pretty much sums it up right there.

#39

actually that tty screen is just what the startup script spit out before starting the wm. I didn’t tell it to.

#40

It would help if you put results from terminal, we would see what s the issues.

#41

at the end. The script runs a good 3 or 4 minutes.

#42

Two very good points made here.

1 Like
#43

We ve been asking to no avail, wonder when we re gonna have the comebacks on these, wonder if @Davi ever looked @ the links above also.

#44

@Davi is there a reason why you aren’t providing the answers to the questions asked? We can’t help if you don’t.

2 Likes
#45

at the end. The script runs a good 3 or 4 minutes.

then try what chris60601 suggested and do Ctrl - Alt - F2 to see if that brings up tty2 so you can log into a different console.

1 Like