How to start at boot


#1

So I installed archlabs now how do I start it? I rebooted and I’m at a command line but I don’t know how to start it up.


#2

If you installed a window manager:

startx

Will log you into an X session.


#3

I installed several. Which one will it put me into or will it give me a choice?


#4

Edit: Almost duplicated what @PackRat wrote above


#5

Do you want to use a login manager? If so, install lightdm sudo pacman -S lightdm and it should take care of configs when installing (I think?). Once installed you’ll need to sudo systemctl enable lightdm.service and reboot.

For the best info go to https://wiki.archlinux.org/index.php/Display_manager first.


#6

Read your ~/.xinitrc the instructions for multiple window managers are explained.

startx

will start the default window manager;

startx ~/.xinitrc <window_manager_name>

can be used for the others.

Or install a login manager like DatNobleSavage suggests.


#7

I followed that . Then i get this…


#8

post the output of systemctl status lightdm.service


#9

But now i cant get to command prompt’. Just this and blinking cursor


#10

Ok, start again and select that you want to install lightdm (plus the greeter, I haven’t installed the latest version of AL so I don’t know exactly what has changed in the installer) plus the WMs and DEs you want to try.

The other way around involves arch-chrooting and is a bit more involved (but simple enough if you want to try that).

However, because it’s a new install, I’d just go with starting again, looking at every option available and reading about the options you don’t know about on the arch wiki.

Fingers crossed, we can get you through this hiccup :slight_smile:


#11

You have access to tty ? (I guess not but it’s worth the try).
Otherwise, just chroot in and remove the systemctl enable you’ve added.


#12

arch-chroot is the more elegant solution but I am guessing from @Davi’s posts that he might not know the full steps to carry it out. Which is why I invited him to install again and select all that he might need.

I didn’t want to take him through the steps of arch-chroot and so on, as it is a new install. Go ahead and let him know how to do the better solution though!


#13

What folks are failing to realize (although ArchLabs strives to be a happy place between Arch Linux and Manjaro) there still is manual intervention required. As a reference point please seek most of your answers at the Arch Wiki.


#14

Hey, so I reinstalled it only to have the same thing happen. I’m at a cl and startx does nothing. I did enable the greeter too. And thinking back I installed it the first time too. I’m still not getting a de or a wm. Just the blinking cursor. Now what? I don’t konw how to chroot, but I’ll follow directions if someone can help me. Or whatever? I just want to get this running


#15

If you did install the OS and all the other bits, then for giggles, enter this command;
sudo systemctl set-default graphical.target
sudo systemctl enable lightdm
then reboot


#16

still no luck. Won’t boot . says won’t boot can’t find d bus, loggin out of x server. okay this distro is beginning to piss me off now.


#17

What --is-- are your system specs?


#18

this is even on a different laptop. An i7. First was an i3. More than enouh to run it.


#19

Post results from terminal (if you can get to one) or get to tty1

inxi -Fxz

Edit: wonder if grub was installed somehow also


#20

I just looked up this inxi thing for the first time. You need to install from the AUR, it isn’t included in the default packages.