ArchLabs Linux

How to Remove Evolution?

I can’t remove evolution-alarm-notify, evolution-calendar-factory, evolution-addressbook-factory, evolution-source-registry

thx

What command are you using? Also would like to see the output from the terminal when you try to remove Evolution.

# pacman -Rus evolution-data-server
checking dependencies...
warning: removing evolution-data-server from target list
warning: removing libgweather from target list
warning: removing libical from target list
warning: removing libgdata from target list
warning: removing libphonenumber from target list
warning: removing liboauth from target list
warning: removing geocode-glib from target list
warning: removing protobuf from target list
 there is nothing to do

# pacman -Rus evolution evolution-exchange evolution-plugins evolution-common evolution-webcal
error: target not found: evolution
error: target not found: evolution-exchange
error: target not found: evolution-plugins
error: target not found: evolution-common
error: target not found: evolution-webcal

# pacman -Rus evolution-alarm-notify evolution-calendar-factory evolution-addressbook-factory evolution-source-registry
error: target not found: evolution-alarm-notify
error: target not found: evolution-calendar-factory
error: target not found: evolution-addressbook-factory
error: target not found: evolution-source-registry

# pacman -Sii evolution-data-server
Repository      : extra
Name            : evolution-data-server
Version         : 3.34.1-1
Description     : Centralized access to appointments and contacts
Architecture    : x86_64
URL             : https://wiki.gnome.org/Apps/Evolution
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : gnome-online-accounts  nss  krb5  libgweather  libical  db  libgdata  libphonenumber
Optional Deps   : None
Required By     : evolution  folks  glabels  gnome-calendar  gnome-notes  gnome-panel  gnome-phone-manager  gnome-todo  pantheon-calendar
Optional For    : gnome-shell
Conflicts With  : None
Replaces        : None
Download Size   : 4.30 MiB
Installed Size  : 41.43 MiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : Mon 07 Oct 2019 04:18:53 AM PDT
MD5 Sum         : e5a70c99f1752f13914242a1c218a3d0
SHA-256 Sum     : 3dcdad91acf33d370e53feb0a65e2d7ff6299769db420a4f2d35a534f0c2e43a
Signatures      : A5E9288C4FA415FA

# pacman -Rus evolution-bogofilter
error: target not found: evolution-bogofilter
# pacman -Rus evolution-ews
error: target not found: evolution-ews
┌ 1 root@myegg /home/johny 
└> # pacman -Rus evolution-mapi
error: target not found: evolution-mapi
┌ 1 root@myegg /home/johny 
└> # pacman -Rus evolution-rss
error: target not found: evolution-rss
┌ 1 root@myegg /home/johny 
└> # pacman -Rus evolution-spamassassin
error: target not found: evolution-spamassassin
┌ 1 root@myegg /home/johny 
└> # pacman -Rus evolution  folks  glabels  gnome-calendar  gnome-notes  gnome-panel  gnome-phone-manager  gnome-todo  pantheon-calendar
error: target not found: evolution
error: target not found: glabels
error: target not found: gnome-calendar
error: target not found: gnome-notes
error: target not found: gnome-panel
error: target not found: gnome-phone-manager
error: target not found: gnome-todo
error: target not found: pantheon-calendar

Doesn’t that mean that none of those applications are installed? There is nothing to remove.

Have you rebooted since removing those? It will still be running even though you have uninstalled.

after rebooting:

i’m guessing i could disable the evo services with systemctl, but that shouldn’t be necessary if the correct packages are removed.

pacman -Sii evolution-data-server lists things dependent on evo, but i can’t remove them. pacman -R on the items listed for “Required By”, gives “error: target not found”.

Have you tried pacman -Rcns

i won’t do a recursive remove without knowing what it’s going to remove. How to determine?

It will list what is being removed.

As an example:

Are you using Gnome-Shell?

@Dobbie03 Feel free to stop commenting if you want. Your choice.

# pacman -Rcns evolution-data-server
checking dependencies...
:: git optionally requires gnome-keyring: GNOME keyring credential helper
:: libproxy optionally requires webkit2gtk: PAC proxy support (Webkit2gtk engine)
:: libsecret optionally requires gnome-keyring: key storage service, or use any other service implementing org.freedesktop.secrets
:: xfce4-session optionally requires gnome-keyring: for keyring support when GNOME compatibility is enabled

Packages (31) aspell-0.60.8-1  bubblewrap-0.3.3-3  enchant-2.2.7-1  folks-0.13.1-2  geary-1:3.34.1-1  geocode-glib-3.26.1-1
              gmime-2.6.23+4+g91dcee38-2  gnome-keyring-1:3.34.0-1  gnome-online-accounts-3.34.1-1  gspell-1.8.2-1  harfbuzz-icu-2.6.2-1
              hspell-1.4-2  hunspell-1.7.0-2  hyphen-2.8.8-2  libgdata-0.17.11-1  libgee-0.20.2-1  libgweather-3.34.0-1  libhandy-0.0.11-1
              libical-3.0.6-1  liboauth-1.0.3+14+g186fb14-1  libphonenumber-8.10.18-2  libvoikko-4.2-1  libwpe-1.4.0-1
              libytnef-1.9.3+7+g24fe30e-1  protobuf-3.7.0-1  telepathy-glib-0.24.1-2  webkit2gtk-2.26.1-1  woff2-1.0.2-1
              wpebackend-fdo-1.4.0-1  xdg-dbus-proxy-0.1.2-1  evolution-data-server-3.34.1-1

i don’t know what some of these are. I could investigate each one, but wondering if there’s an easier way. Seems very time-consuming.

i ran pure arch, xfce, geary without evolution. Wondering why geary wants evo on archlabs.

I’m actually trying to help. No need to get uppity.

I’ll ask my question again, are you using Gnome Shell?

Unsure, but i think not:

# whereis gnome-shell
gnome-shell:

└> # pacman -Q | grep gnome
gnome-disk-utility 3.34.0-1
gnome-keyring 1:3.34.0-1
gnome-online-accounts 3.34.1-1
gnome-themes-extra 3.28-1
polkit-gnome 0.105-4

└> # echo "$SHELL"
/bin/bash

What desktop environment or window manager are you using? You must know, you would have selected one when installing ArchLabs.

xfce. no DM.
i uninstalled geary, that seems to have removed evo data-server. evo processes are still running, tho’

i’ll reboot and check…

$ pacman -Sss evolution
extra/evolution 3.34.1-1 (gnome-extra)
    Manage your email, contacts and schedule
$ sudo pacman -S evolution
resolving dependencies...
looking for conflicting packages...

Packages (17) dbus-glib-0.110-1  evolution-data-server-3.34.1-1  geocode-glib-3.26.1-1  gnome-autoar-0.2.4-1  gnome-desktop-1:3.34.1-1  gnome-online-accounts-3.34.1-1  gspell-1.8.2-1
              libcryptui-3.12.2+41+gf29d1d37-2  libgdata-0.17.11-1  libgsf-1.14.46+3+g7f927f0-1  libgweather-3.34.0-1  liboauth-1.0.3+14+g186fb14-1  libphonenumber-8.10.20-2  libpst-0.6.72-3
              libytnef-1.9.3+7+g24fe30e-1  protobuf-3.10.0-1  evolution-3.34.1-1

Seems like it’s a part of gnome to me.

If you really want to remove it then

pacman -Rnsc evolution

and deal with whatever arises.

Alrighty. Just so you know GOA is a required part of Geary. It is there so you can sign on to your chosen email provider. Don’t remove it or these other packages.

Otherwise Geary won’t function correctly.

If you want an email client on your desktop that doesn’t require these dependencies then use Thunderbird.

1 Like

goa? You’re referring to my other thread?

after rebooting the evo tasks are gone (i didn’t look at goa).
then i reinstalled geary, and now just getting:
with geary not running: evolution-source-registry
with geary running: evolution-source-registry, evolution-addressbook-factory.

will now trying rebooting again, since haven’t yet rebooted since installing geary.

Yep both these threads should be merged as they are related,