How to make window persist in float after fullscreen

Some window like mpv, I prefer it to float (for video/podcast purpose), but when i do full screen with (f - mpv default fullscreen key) or F11(dkcmd) and exit out of fullscreen, the window occupies whole screen (like mono).

I tried to set rule saying
dkcmd rule class=“^mpv$” float=true

Then too doesnt float after fullscreen. This is true for all windows!

Please let me know if i missed any rule setting for it. If not, this should be implemented!

I’m very grateful to you, Nate, to have developed such an amazing wm.

Its combines dwm + bsp for me. It made my work very ease. I have been recommending people to try it, as many people will find it great for their workflow.

Thank you!

Can you post pics of what it does please ! Might help a bit .

Im not able to post images, I will post link for image if you didnt get it.

As i stated.

Its same for terminals or other windows too.

Open a window in floating and fullscreen it with F11 and exit with F11, it will be taking max space.

Hope its clear, if you can replicate the same.

See, this is float of mpv


This is fullscreen with F11 or f key

This is after exiting fullscreen with f or F11 key

The blue border in 3rd image is the window border, which means mpv/window is floating but taking up full screen like mono.
I want that window to take initial float size (position and size)

Hope its clear!
I could have said in simplified way lol

Oh, thx, wonder why you can t post pics on your end.

Their s a Upload icon around the middle top (rectangular shape) where you type your posts.

No worries, ! lol Some times I m not that clear either !

If you press the ESC key on left top of keyboard, what it does, it should get you out of full screen I think.

Wait… I guess you didnt get my point.
Im not talking about how to exit fullscreen.

The issue is, when i come out of the fullscreen window which was floating, it float occupying full screen.

See 1st and 3rd image for reference.

Oh, well, guess that someone else will need to help you out on that one, as I can t help you on that part.

Guess that you mean that either Tint2 or Polybar or whatever used doesn t show back on when extiting fullscreen right ! & that YouTube or whatever doesn t come back to a smaller size also, we ll get there ! lol

See if “rule MATCH float=true stick=true” helps.

https://bitbucket.org/natemaia/dk/src/master/README.md

No, it doesnt change.

No not in floating mode tried myself, there is no back to float from full screen.
This is from i3wm something like this may help. ? nade
popup_during_fullscreen smart # smart|ignore|leave_fullscreen

Looks like an issue. Can you report it here?

The window returns to floating, but keeps the full screen width and height. The pre-fullscreen dimensions are not preserved.

Tried setting a width and height for the window:

dkcmd rule class="^pavucontrol" float=true focus=true w=800 h=600

and that didn’t work.

Use that link chroot provided and file a report with @natemaia

2 Likes

I was tried the same method with my scratchpad. I don’t have a copy of i3 anywhere to test. dk rules

dkcmd rule class="^scratchpad$" float=true x=800 y=28 w=1000 h=600 
1 Like

I raised the Issues.

1 Like

Sorry this has taken me a bit to deal with especially given how simple the fix was, should be solved now with the latest commit.

Thanks for bringing it to attention