How to make Archlinux boot into high resolution every time


#1

For the last couple of days, every time I have tried to boot into Archlabs, it boots into a low resolution screen on startup (800 * 600 screen). I did not face this problem in the past, or even if I did, a reboot would fix this. What do I need to do to make sure I boot into a higher resolution screen each time I boot? I searched the archwiki archives, I could not pinpoint an answer.

Can you please provide some guidance?

My system:
Archlabslinux
Thinkpad X220i
Openbox and i3wm


#2

I’m not sure of your resolution but this is what I have in i3 config and openbox autostart

i3wm:

exec --no-startup-id xrandr --output DisplayPort-0 --mode 3840x2160 --pos 0x0 --rotate normal --output DVI-D-0 --off --output HDMI-A-0 --mode 3840x2160 --pos 3840x0 --rotate normal &

openbox:

xrandr --output DisplayPort-0 --mode 3840x2160 --output HDMI-A-0 --auto --right-of DisplayPort-0

Obviously mine is setup for dual screens so adjust as you need. Reboot for it to take effect.


#3

First you need to find your native resolution if it not detects. You can check output of xrandr command to see supported modes.
Then you can use commands from Dobbie’s post to set it permanently.
You don’t need to reboot, you can restart X with ctrl+alt+backspace usually.


#4

That function will be removed in the next AL release. Though good call there.


#5

other option will be systemctl restart lightdm so the X will be restarted together with login manager.


#6

Thanks @Dobbie03 and @dimaom for your kind words and advice. It did not resolve the issue.
Not sure what will fix it.
If I shutdown and start again, the computer boots into a low resolution screen, then if I shutdown and start several times, at some point I get into a high resolution screen.


#7

Touchy video card / drivers?


#8

Is this happening on both i3 and openbox?

Can you post your Openbox config and i3 config.