How to fix the system tray for gnome in archlabs

hello everyone :slight_smile:
noob here, i just installed archlabs last night on this laptop and finally got the nvidia drivers to work. my new problem is gnome doesn’t seem to display the icons of the apps that would normally be in the system tray:

like steam, qbittorrent, and this wallpaper app i use called variety.
I suspect it is the same problem why gnome is also showing an empty notifications tab when you click on the clock. (but this might be a separate problem)

does anyone know how to get the systray icons to show?
thank in advance :slight_smile:

I haven’t ever installed AL with the GNOME session, but, if I remember well, GNOME does not support the system tray by default. You need to install and enable gnome-shell-extension-appindicator.

4 Likes

I see thank you for replying :slight_smile:

I just installed that package you linked through yay

do i just reboot now?

You need to turn the extension on. Find something similar to this:

1 Like

ahah, yeah that fixed it thanks

Great. Mark as the solution, please.

1 Like