How often do you upgrade your systems?


#21

Bingo! Same here. Pamac-Tray is a beautiful thing. For the actual updates, good old yay -Syu for me.


#22

It works, but I’m a bit ashamed to have it on screen shots. :wink: That’s why I use this:

image


#23

Love your work @nwg but that’s tint2, wouldn’t work in Cinnamon’s panel, which is what I use it for.


#24

I know nothing on Cinnamon. Couldn’t it be applicable in any way?

image


#25

I suppose a cinnamon panel applet could be written, what’s wrong with pamac as an indicator? I’ve 20gigs of memory and I’m certainly not ashamed of using it as such. As I stated above, I don’t recommend using it to install or update by but it serves it’s purpose. :slight_smile:


#26

Surely nothing, besides what I wrote above. :wink: I keep pamac installed, too, as my package browser.


#27

Not a bad idea, I suppose if you’ve not the exact package name that would be handy. I don’t install enough packages for that purpose though.


#28

I also tried PkgBrowser, but it’s uncomfortable, and looks ugly (Qt).


#29

Not exactly sure how to use this. I’ll read some info. However, the lines I had were confortable. The system booted with or without the drives being connected and now it no longer does. The drive has to be there or I get errors. Very annoying change.


#30

Just to be sure, you only have updated your system and it no longer works properly ?

I’ve checked my fstab, my data disk and also my swap partition use 0 0 instead of 0 2 and they mount at start as intended. Might be worth trying, anyway it’s odd…


#31

I only updated. Yes. Nothing changed. The problem is that the external drives mount ok. That’s not the issue. The issue is that now I get errors when the drives are not present! The nofail option worked perfectly before the update. Changing the disk check to 0 0 did not help either. The drives must be present!


#32

My bad, misread it.

From SO, the nofail option might have to be placed after auto (https://askubuntu.com/questions/14365/mount-an-external-drive-at-boot-time-only-if-it-is-plugged-in).

Why did you try noauto ?


#33

DId you manually add those entries for those drives in fstab yourself? If you did then every time you boot fstab is going to be looking for those entries every time, if the drives aren’t found you are going to have trouble booting.


#34

Yes. Added them manually. It has always worked perfectly. With or without the drives being connected. That’s what the nofail option took care of. If the drive was not present at boot time it was no problem. If I connected it later it was mounted automatically. After the update it no longer works.


#35

Because my original fstab lines did no longer work and I still want the defined mount point for the drive if I (later) mount the device manually


#36

Might be related. Anyway, you have no luck, last update that “broke” the system was something like 5 months ago :frowning:


#37

Thx for sharing @gazeka74 . Better wait before updates for a little while till it gets fixed.


#38

already did, no issue so far for me. But yeah, better wait a moment before updating.


#39

Yep , I would like arch to have something similar to debian concerning bugs updates as Apt-listbugs, saved by !ss several times after I know about it on sid or sid-derived distros.


#40

Issue solved. I changed the fstab line for the external USB drive to:
UUID=xxx /media/touro ext4 rw,noatime,noauto,x-systemd.automount

The system boots normallly, with or without the drive connected. The drive is automounted and fsck’ed after the first access to it. So I’m a happy ArchLabs user again.