How i install archlabs with wifi

Hi i wanna install arch labs but my scare are getting no wifi during the installation. please help me how to install the wifi on the installation the wifi Thanks! sorry for the bad english

1 Like

Welcome to the forum.

What is the model of your wifi card? ArchLabs supports most.

Boot from the latest iso. It’s a fully functional command line environment. From the console, you can enter:

nmtui

to start the NetworkManager ncurses based application and connect to your wifi. Once connected, you can run the installer. Should automatically configure your wifi during install and be enabled when you reboot post install.

2 Likes

how i see my wifi card model its from a lenovo laptop now im on arch craft and it works well

1 Like

post,

$lspci

and,

$ip a

2 Likes

lspci
00:00.0 Host bridge: Intel Corporation Device 8a02 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Iris Plus Graphics G1 (Ice Lake) (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 8a03 (rev 03)
00:14.0 USB controller: Intel Corporation Ice Lake-LP USB 3.1 xHCI Host Controller (rev 30)
00:14.2 RAM memory: Intel Corporation Ice Lake-LP DRAM Controller (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Controller #0 (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Controller #1 (rev 30)
00:16.0 Communication controller: Intel Corporation Ice Lake-LP Management Engine (rev 30)
00:17.0 SATA controller: Intel Corporation Ice Lake-LP SATA Controller [AHCI mode] (rev 30)
00:1d.0 PCI bridge: Intel Corporation Ice Lake-LP PCI Express Root Port #9 (rev 30)
00:1d.4 PCI bridge: Intel Corporation Device 34b4 (rev 30)
00:1f.0 ISA bridge: Intel Corporation Ice Lake-LP LPC Controller (rev 30)
00:1f.3 Audio device: Intel Corporation Ice Lake-LP Smart Sound Technology Audio Controller (rev 30)
00:1f.4 SMBus: Intel Corporation Ice Lake-LP SMBus Controller (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP SPI Controller (rev 30)
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
06:00.0 Non-Volatile memory controller: SK hynix BC511

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:45:e2:1c:98:d1 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.12/24 brd 192.168.0.255 scope global dynamic noprefixroute wlan0
valid_lft 20243sec preferred_lft 20243sec
inet6 2800:484:368d:6000::4/128 scope global dynamic noprefixroute
valid_lft 1956sec preferred_lft 1956sec
inet6 2800:484:368d:6000:1049:dbd6:8ed5:6d35/64 scope global dynamic noprefixroute
valid_lft 1196609sec preferred_lft 591809sec
inet6 fe80::f3fd:2798:44bc:28c5/64 scope link noprefixroute
valid_lft forever preferred_lft forever

its here

1 Like

You have a RTL8822CE card in the system. It seems already configured. Can you verify your connection by,

$ping google.com

1 Like

If you have not yet tried I suggest you boot the iso and try to start the installer, it will try to connect and prompt you to select a network. Unless you have a few specific cards it will work and you can go from there.

3 Likes

So thanks all for the help now I’m running Archlabs and it looks and felt amazing

3 Likes

Glad that it s working on your end @4Dk3 .

Please mark it as solved & what was the solution , it might help some other members in the future, never know.

Enjoy