Hibernate function?


#1

Good day forum,

Is there any way to add a hibernate and suspend option to the “log off” menu (ctrl+x)?

Grand Admiral Thrawn


#2

Don’t think so. You can always add these option to your oblogout config?

https://wiki.archlinux.org/index.php/Oblogout


#3

You would need to edit the ~/bin/rofi-logout script and add those options.

This what you’re after?:

There is a ~/bin/rofi-logout.template file you can use to create a new rofi script with the options you want. Save it to a different file name and remember to make it executable.


#4

I love that logout menu.

If I change my oblogout keybind to the rofi script, it should work?


#5

Yes.

Or give it a new keybind for some redundancy; then you have two ways to gracefully exit should one script become corrupt.


#6

Sorry mate, I can’t find ~/bin/rofi-logout.template mate :confused:


#7

You can use this - rofi-logout

That’s the script I used for the screenshot above.


#8

So you are telling us that we need to edit this script, but where is this file as it is not on my computer.


#9

Looks like it was removed from the newer releases.


#10

Damn! If I were you I would remove the solution to the comment above.


#11

@anon37670755 , got a big bump there, 6 months ago it was ok, might have changed with all of firmware & Linux changes/updates since then.


#12

Do you know anything else to enable hibernate funcitonality? If Manjaro has it (with their latest updates) how come ArchLabs doesn’t have it?


#13

@anon37670755 , nop, never use/used this function, someone else might help you out.


#14

Get the script from the link provided, remember to make it executable.

Or add the command to the default jgmenu, or make an openbox key binding.


#15

Sorry bro where is the link that was provided?


#16

Scroll up a bit, link starts with “You can use this …”


#17

Again, please show a little consideration and take the time to actually read what others have wrote. Particularly when they’re generously trying to assist you.


#18

Sorry I see the link now I could’t see cause it is quite dark.


#19

In the upper left corner click on your image, then on the “Preferences” gear, on the left side scroll down to “Interface” and change the “Theme” to your liking, do not forget to “Save changes” (lower part)

I hope it helps!


#20

Never knew you could change the theme for this, thanks for the info.