Help please - trying to install ArchLabs Linux for the first time

I installed the latest ArchLabs Linux a couple of days ago, and I am not able to get it working.
I ran throught the installation without any issues. When I rebooted (without the installation media) I do see the GRUB menu, and can select the ArchLabs Linux entry.
After that I see some console messages and after that I get a black screen with the cursor blinking in the top right corner.
I’m not sure of where to look next for information on what the problem is or how to resolve it.
Thanks,
Carl

When the GRUB menu appears, push “e” to edit. At the end of the kernel line where you see the word “quiet,” delete it and add a “3” to the end. Push F10 to continue to boot with the changes, and you will be at the command line, and able to log in. There is a chance you still may not be able to boot. If so, please let us know, else follow the instructions below, and provide us with any info you learn that could help solve your issue.

Once logged in to your system run the following:

journalctl -xe | grep error   # Repeat grep with fail and panic; checking for clues to why you black screened.
cat /var/llog/Xorg.0.log | grep error # Repeat with fail
systemctl --failed  # Check to see if the DM failed.

Hello, and thanks for your reply.
I was able to follow your instructions and was able to boot and log in.
Here are the results of the commands you asked me to enter:

journalctl -xe | grep error
Feb 28 21:53:40 archlabs NetworkManager[256]: [1519876420.0185] keyfile: error loading connection from file /etc/NetworkManager/system-connections/system-connections: File did not exist or was not a regular file
Feb 28 21:53:41 archlabs kernel: traps: lightdm[271] general protection ip:558ae240420b sp:7ffc9086ad80 error:0 in lightdm[558ae23f1000+40000]
Feb 28 21:53:42 archlabs kernel: traps: lightdm[296] general protection ip:55d571c5120b sp:7fff536668f0 error:0 in lightdm[55d571c3e000+40000]
Feb 28 21:53:43 archlabs kernel: traps: lightdm[304] general protection ip:55a37d9fa20b sp:7ffc1726c8c0 error:0 in lightdm[55a37d9e7000+40000]
Feb 28 21:53:43 archlabs kernel: traps: lightdm[311] general protection ip:55ee6db7620b sp:7fff847691a0 error:0 in lightdm[55ee6db63000+40000]
Feb 28 21:53:44 archlabs kernel: traps: lightdm[318] general protection ip:557f31aa820b sp:7ffee9bef930 error:0 in lightdm[557f31a95000+40000]
Feb 28 21:54:59 archlabs NetworkManager[256]: [1519876499.8078] keyfile: error loading connection from file /etc/NetworkManager/system-connections/system-connections: File did not exist or was not a regular file

journalctl -xe | grep fail
Feb 28 21:53:42 archlabs ntpd[272]: bind(24) AF_INET6 fe80::8d37:b4b:f426:1f9d%2#123 flags 0x11 failed: Cannot assign requested address
Feb 28 21:53:42 archlabs ntpd[272]: failed to init interface for address fe80::8d37:b4b:f426:1f9d%2
– Subject: Unit lightdm.service has failed
– Unit lightdm.service has failed
Feb 28 21:54:53 archlabs kernel: acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
Feb 28 21:54:53 archlabs kernel: acpi PNP0A03:00: fail to add MMCONFIG information, can’t access extended PCI configuration space under this bridge.
– Subject: Unit systemd-modules-load.service has failed
– Unit systemd-modules-load.service has failed

journalctl -xe | grep panic
no results

cat /var/log/Xorg.0.log | grep error
(WW) warning, (EE) error, (NI) not implemented, (??) unknown
Fatal server error:
[ 16.251] (EE) Server terminated with error (1). Closing log file.

cat /var/log/Xorg.0.log | grep fail
[ 16.201] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

systemctl --failed
UNIT LOAD ACTIVE SUB DESCRIPTION
. systemd-modules-load.service loaded failed failed Load Kernel Modules

Here is more from /var/log/Xorg.0.log

[ 16.201] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 16.201] (II) loadModule: “glx”
[ 16.201] (II) loading /usr/lib/xorg/modules/extensions/libglx.so
[ 16.205] (II) Module glx: vendor=“X.Org Foundation”
[ 16.205] compiled for 1.19.6, module version = 1.0.0
[ 16.205] ABI class: X.org Server Extension, version 10.0
[ 16.205] (==) Matched sis as autoconfigured driver 0
[ 16.205] (==) Matched modesetting as autoconfigured driver 1
[ 16.205] (==) Matched fbdev as autoconfigured driver 2
[ 16.205] (==) Matched vesa as autoconfigured driver 3
[ 16.205] (==) Assigned the driver to the xf86ConfigLayout
[ 16.205] (II) LoadModule: “sis”
[ 16.205] (WW) Warning, couldn’t open module sis
[ 16.206] (II) UnloadModule: “sis”
[ 16.206] (II) Unloading sis
[ 16.206] (EE) Failed to load module “sis” (module does not exist, 0)

It seems like it is having a hard time with the video hardware. I know that there is onboard video (no video card). Plus this is an older machine.
I will boot from the CD tomorrow and then check out this log file to see why it is being successful.

At some point, open a terminal and run the following:

lscpi -k | grep -i VGA -A3

It appears you might be missing a Xorg package for the video driver… So, we need to find out which driver is in use by the kernel before continuing.

lspci -k | grep -i VGA -A3

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
Subsystem: Lenovo 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

Almost have it, missing one small part that is needed. The kernel driver is missing from the 3 lines of text captured.

lscpi -k | grep -i VGA -A6

By increasing the -A3 to -A6 we can capture 6 lines of text… Increase as needed, until you see the kernel driver listed.

Hello…
Unfortunately there are no kernel drivers listed. Those 2 lines are the last lines in the listing. I tried:
lspci -k
lspci -v -k
lspci -vv -k
lspci -vvv
lspci -vvvv

That last command is probably the most verbose. Here is the output:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
Subsystem: Lenovo 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWinv- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 10
BIST result: 00
Region 0: Memory at e0000000 (32-bit, prefetchable) [size=128M]
Region 1: Memory at ec000000 (32-bit, non-prefetchable) [size=128K]
Region 2: I/O ports at 9000 [size=128]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] AGP version 3.0
Status: RA=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3+ Rate=x4,x8
Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=

Interesting…
Run

pacman  -Qi xf86-video-sisusb

If the package is not installed… Install it via pacman -S xf86-video-sisusb and do a test reboot without modifying the grub config.I suspect this is the driver that is missing.

I ran the first command, and that package is not installed.
I ran the second command, and the package was installed successfully.
I rebooted, and I still get the black screen with the blinking cursor in the top left corner of the screen.
Later today I will check the logs to see if anything is different in them.

Check the logs, but I am curious, what the live cd, is using for the kernel video driver, if any, and the Xorg driver. So, I would also check there as well. I think this may help as well.

Yes. I was looking at that yesterday too, but I ran out of time. I have an additional question:
When I have booted up my computer (without the live cd) and following your instructions I get to a command prompt. I would really like to be able to mount a usb thumb drive at that point (so I can copy the log file output). So far I have not been able to do that. I checked the /dev directory but I don’t see the usb drive there. Any suggestions?
Thanks,
Carl

To mount the usb, for this particular instance, we will mount it to /mnt, instead of media.

Open root with:

sudo -s # This gives temp root access
mkdir -p /mnt/USB  # if you have not already plugged in USB drive, plug it in.
lsblk     # This will display all drives that are currently accessible. Look at output and find the USB
mount  /dev/sdx1 /mnt/USB  # File system should auto-detect for VFAT, and standard linux FS.
## Copy logs to drive, and unmount the drive
umount /mnt/USB
## exit root environment
exit

I’ve logged in with the Live CD. Here are some of the messages in journalctl:

(hope this works)

I’m still logged in using the Live CD. Here the Xorg.0.log:

Still logged in using the Live CD. Here is the output from systemctl:

Still logged in using Live CD. Here is the output from lspci -vvv

And lastly (for now) I found this:
https://packages.ubuntu.com/search?keywords=xserver-xorg-video-sis

Wondering if I should try to figure out how to install this. It might have the drivers I need.

and then I found this: https://aur.archlinux.org/packages/xf86-video-sis/

After a read through of the Xorg log, the driver in use, seems to be the xf86-video-vesa package. So, I would uninstall the xf86-video-sisusb first, and install the vesa package. Attempt the reboot, if the vesa package does not restore the video, then give the AUR package xf86-video-sis, a try. But, there is a known issue with this package

thx1138 commented on 2017-04-04 21:26

A git bisect tracked this back to
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=90a545e981267e917b9d698ce07affd69787db87

The quick fix is the “iomem=relaxed” command line parameter, which will be required with the Arch kernels from 4.5 and later.
thx1138 commented on 2017-03-18 04:12

This driver works fine with the older linux-lts 4.4 kernels, but has a problem with later kernels, where the log ends with:

(EE) SIS(0): Unable to map FB aperture. Invalid argument (22)
(EE) SIS(0): **************************************************
(EE) SIS(0): ERROR:
(EE) SIS(0): SiSMapMem() failed
(EE) SIS(0): END OF MESSAGE
(EE) SIS(0): **************************************************

Something changed between the 4.4 and 4.5 kernels, if anyone wants to track it down, possibly related to libpciaccess.