Help, chrun 'pacman -S' error!

Hi guys!

I am trying to install Archlabs on my computer, with a dual boot with Windows 10. But, when Pacman -S tries to install the packages that i selected, it just fails. I really don’t know what to do, so please, somebody help me.

(Ps: I am new here.)
(Ps: Btw, sorry for the bad english.)

Hello, me and some others community members have the same problems, and we find help here:


at post number 13 @natemaia kindlly post a link to the new beta installer, and in post 28 he explain " Ok, qt5-styleplugins no longer exists in the Arch repos so any Qt applications would have caused a fail. This is now fixed and should avoid future cases where packages we add get removed from the repos."
I have installed Openbox with only few packages and the install went well

Oh yes!
I must have missed this with a link to a beta-iso with lesser bugs.
Please pretty please publish the link here!

womp

Please try this beta iso I linked in another thread and let me know if you run into issues, I’ll walk you through it if needed.

Referring to here:

Try these steps:
-Use natemaia’s beta ISO shown above and flash it to a USB stick
-before running archlabs-installer, run these two commands:

mkfs.vfat -F32 /dev/nvme0n1p1
mkfs.ext4 -q /dev/nvme0n1p2

remember to replace the above labeled partitions with your actual partitions. (Nornally these are /dev/sda1 and /dev/sda2 respectively for SSDs)

Now run archlabs-installer
-once you reach the main menu, skip down to option 4.1 “mount partitions” and follow the instructions to reformat your GRUB and ROOT partitions. Do NOT reformat your partitions using option 2 in the main menu.

-continue on as normal

In my opinion it’s worth a shot; it fixed a similar problem for me.

Hi!!
I did an install on a macmini 4.1 (2010) and it installed! The only problem I had was that installer would not create swapfile.
I have problems on reboot though. Nvidida-340xx-dkms will not build.

womp

I don’t know about the nvidia issue, perhaps start a separate thread and post the error messages you have.

The swapfile issue is recent, mkswap won’t accept files with holes so I need to use dd not fallocate. You can follow the arch wiki for setting up one yourself.

1 Like

Yeah! Thanks no problem!

womp

Hi again!
After 3 more installments with success (except for the swapfile) I am back in “Archlabs-land”!!
I feel good…

womp

1 Like

Glad it worked out for you @womp

As for swap, I don t use it for quite a while. & with just 8 GB RAM

1 Like

Thanks!!
I am on laptop here but I will try with no swap for a while.

womp

1 Like

Cool , also on a laptop, forgot to mention it.

1 Like

And you haven’t been through any “stand-still”?

womp

1 Like

Nop, with 8-10 firefox windows opened.

1 Like

That’s great (and crazy!)

womp

1 Like

Just make one, it only takes a few minutes and a handful of commands

su
dd if=/dev/zero of=/swapfile bs=1M count=$(awk '/MemTotal/ {print int($2 / 1000)}' /proc/meminfo) status=progress
chmod 600 /swapfile
mkswap /swapfile
swapon /swapfile
echo "/swapfile none swap defaults 0 0" >> /etc/fstab

If you do run out of ram all that will happen is the kernel will start freeing up memory where it can, either internally or by killing processes. Shouldn’t experience any kind of lock up.

2 Likes

Hi today I tried an Archlabs install on an old Dell Latitude 6430 (intel, very compatible except for the bcm43228)
I tried 3 times and got different errors all three times.
First time the installer got time-out errors rather early in the install.
Second time the installer got errors early in chroot.
Third time I didn’t understand the error but there were rectangular signs arround bash that gave installer error.

I humbly wonder it you have a new beta on the way?

womp

1 Like

As @natemaia stated in another thread that I can t find, please update the installer before update, might do the trick hopefully @womp .

1 Like

Yeah, I know! I did update the installer (at least I tried to. I don’t know if “it took”.

womp

1 Like

pacman -Q archlabs-installer

1 Like