Hello-al not installing nvidia drivers

I am trying to migrate over from antergos and am having trouble getting nvida drivers installed. I have a GTX460 and know what drivers I need but am having difficulty getting them installed.

I am admittedly pretty unfamiliar with arch but have done my best to read about what I should do but am coming up short.

I have reinstalled several times and have verified the hash of the download is good so I am not sure why the script isn’t installing the drivers for me. Any advice would be greatly appreciated (if I left out important details I am happy to add them sorry in advance).

After continuing to mess with this still can’t figure out how to get these drivers installed the nouveau drivers persist.

I am able to circumvent the gfx card by disabling it in bios and using onboard gfx from my mobo. :confused:

Just do it manually, this is very basic stuff and it is assumed if you’re using an Arch based distro you know how to do things like install packages.

# install nvidia-390xx drivers, these are the last drivers to support nvidia fermi
sudo pacman -S nvidia-390xx nvidia-390xx-settings nvidia-390xx-utils libxnvctrl-390xx libvdpau lib32-libvdpau

# you may set up and configure your driver settings using the following
sudo nvidia-xconfig && sudo nvidia-settings

After a reboot you should have everything set up, double check by running nvidia-settings again.

You can get more info regarding nvidia configuration in Arch based distros here https://wiki.archlinux.org/index.php/NVIDIA#Configuration



Thanks for the assistance. I tried following the arch wiki before posting silly of me not to mention it.

I broke the system several times trying to install the drivers. After installing via pacman sudo nvidia-settings says that I don’t have the drivers installed.

I am going to mess with this some more this evening but for whatever reason noveau drivers are not being replaced. This is probably very naive of me and I can most likely just use the integrated graphics but since I can’t get it to work its making me want to get it even more.

Thanks in advance for any help.

1 Like

Hi mate. No, you are not naive. I have the same problem since 3 days. In the past few years i install ca. 100 times the nvidia drivers without any problems. Since 3 days nothing happens and i have to reinstall the whole system 4 times. Now i use the nouveau drivers as default. New goal: Less proprietary stuff, more open source.
…pssssst…If you find a solution, please tell me… Greetings


sudo nvidia-xconfig

write a new config file to /etc/X11/xorg.conf ?

then reboot followed by;

sudo nvidia-settings

The other possibility that comes to mind is blacklisting nouveau;

Create a blacklist_nouveau.conf in /etc/modprobe.d and add ‘blacklist nouveau’ and do the same in /etc/modprobe.d/modprobe.conf


You probably know all the above…just trying to help.

1 Like

Hey! Thank you for your help. It is very nice. I have tried all the things above. When i reboot, the boot process stopped at a tty and than nothing. Every f… time. But it is OK. The nouveau driver is good too. Greetings

Good luck! I am sure an nvidia expert must be able to solve this for you…

1 Like

I had tried to do those things as well Mrneilypops thank you very much for commenting/trying to help I really appreciate it. I am also just using the nouveau drivers.

Last night I tried to get the package from Antergos that installs nvidia-drivers correctly on antergos and it also didn’t appear to disable the nouveau drivers/enable nvidia drivers.

I imagine this is something that is pretty basic. I will keep trying but there does seem to be something wrong with the script in the installer.

Have you tried disabling kernel mode setting as described here https://wiki.archlinux.org/index.php/NVIDIA

This is already included in ArchLabs (with minor modifications) and can be found in /usr/bin/install-nvidia