Ghostwriter dependancy issue maybe? I'm such a noob


#1

All I want to do is edit some markdown. After playing with a few apps, I found I really liked Ghostwriter and I’ve been using it for a few months now.

After doing some updates today, Ghostwriter fails to launch.

The error is:
error while loading shared libraries: libhunspell-1.6.so.0: cannot open shared object file: No such file or directory

So I assume libhunspell updated. I peeked into the usr/lib directory and see libhunspell-1.7.so.0

Am I just stuck waiting on the ghostwriter dev or whomever is updating the package in AUR to make changes before I can do any document editing? That’s very frustrating. Maybe I should go back to pen and paper?

Any Linux wizardry I’m missing?


#2

Alright. I was tempted to do the “turn it off and back on” solution, that is reinstalling the app. Then, as I read about the error, I saw that this was a real solution. I reinstalled it, but when pacman wanted to use the existing build, I told it to rebuild all. And now it is working.


#3

Glad that you fixed it yourself, keep it on @sikkdays


#4

Thanks. I appreciate the encouragement. Now, if I could spend some time playing with backlight and a few other hardware incompatibilities that are happening, I might be pretty comfortable. I was just hoping to get a new laptop and not have to solve those issues. However, nobody wants to buy the old Macbook I was trying to get rid of. haha.