ArchLabs Linux

Fresh Install Problem on Virtual Box

Beginner Linux user here. I got intrested in Arch and when I discovered Arch Labs I got excited and decided to set it up on Virtual Box.
Everything works out of the box up until I login then I get some information about pixman and then I get logged out, then it just repeats.

here is a screencap of the problem – https://imgur.com/iwCvKDh

Can get to a different tty with Ctrl-Alt-F2 then

rm -r /etc/X11/xorg.conf.d

I’m not entirely sure if this is the cause but it’s been an issue in the past, you can also check if the vbox modules are installed and for the right kernel

uname -r # kernel name
pacman -Qss virtualbox

Other than that I’m not sure but will do a virtualbox install tomorrow to see.

I installed in vbox just fine so unless you can provide some more info there’s not much more I can do here.

Hi there, I did what you asked me to do and even installed some virtual box packages. Didn’t work.
I reinstalled the Labs but this time I picked sddm - Simple Display Manager. It worked!
I had been using ly - TUI login. Seemed that was the problem.
Thank you for your help.

Awesome glad you got it figured

A good thing, please mark it as solved as it can help in the future.