ArchLabs Linux

Freeze since a yay update (and picom stuff)

Hi.
Since that last update, the system will freeze if I launch something like mpv and some others apps, but it also does it with some non-graphic stuff in the terminal (exemple: neofetch)
I don’t have a clue of what’s really going on but it will freeze each time I try to launch these apps, even in the tty (where i log in before launchin i3).
To be honest it’s unusable…
Also for the picom thing, it doesn’t launch at start like compton did, i have to start the config manually using paranoid.
Thank you if you have some clues.

Edit: I have not installed the new archlabs, I’m still on an older one, and I have waited a long long time before updating, as a result a trillion things have been updated, some were replaced, I don’t know where to search, that’s why I have some difficulties. I…don’t want to reinstall… :confused:

Edit2: The freeze when launching some apps is gone if I downgrade to my previous installed kernel (5.2.13), I can’t explain what it was, still have to fix picom

I’ll look into it tonight, I saw the switch but since I don’t use it i haven’t had any issues and just ignored it for the most part.

I believe compton is just a symlink to pick now so startup should work but can you post the output of

compton -b &

Here the output:

Ok first kill the existing instance then run again.

All the deprecated options should also be removed from your config or grab our latest from the skel-base package in /etc/skel

there is no supplementary line in the output, that last line just disappear.
I will take a look in /etc/skel and also try to find where was the thing that launched the compositor at startup.

1 Like

What WM are you using?

I use i3, I haven’t found anything about an exec compton in ~/.config/i3/config, just al-compositor (uh ?), which seems to not do anything if I execute it in the terminal, it’s that ?

Yes and it does start Compton but redirects the output so you won’t see any. I’d suggest switching to just starting picom from your i3 confif instead as we’re trying to phase out custom startup scripts.

1 Like

I will try with this, it replaces the old line, so al-compositor is not called anymore, just picom. I’ll see tomorrow what will be the result.

exec --no-startup-id picom -b

Thank you.

1 Like

Strange, in my openbox installations, he’s still using compton -b &

another thing strange is that I have the same bug that him about the network icon:


But that is somethin else of course.
Also picom breaks each time i launch something full screen and it results as something really psychedelic, so I kill it and restart it.
I…have learnt the lesson, I will never update again if a few months have passed without pacmaning the OS

If youre going that long without updating and you have issues you dont know how to solve post update then I don’t think rolling releases are the best option.

Regarding the network icon and other polybar related issues, we’re trying to phase out and stop supporting polybar but I’ll look into it tonight as well as picom.


If you read the output and look at the files you’ll see that /usr/bin/compton is just a symlink to picom and that it will be phased out in the future so you should use the actual binary name picom going forward.

seems like just running picom from your startup file works fine. I also really suggest grabbing a fresh config from our skel repo and placing it in ~/.config/picom.conf
https://bitbucket.org/archlabslinux/skel/src/master/base/.config/picom.conf

the exec command works fine indeed.
Also I was wrong about things glitching in fullscreen, it’s just wine apps apparently, it makes picom angry when I quit them for some reasons (so: killall picom && picom -b). The rest works like before. For why everything freeze with the latest kernel, I will wait for the next one and test again.
Thx.

1 Like

You might have better luck with the LTS kernel @k43r17h , just try it out, we never know.

Yea I’m not sure either, fingers crossed the next kernel release fixes it.