Failed to start session


#21

I’ve just tried 2019.01.02. I saw a lot of great changes, and don’t have a black screen every other screen. But, when I rebooted, all I get is a black screen and have difficulty getting tty1 up to try and get to the log in screen. Am I missing something?


#22

Not too sure, can you get to a terminal at any point?

The only thing that comes to mind which could be holding X back from starting would be configuration files in /etc/X11/xorg.conf.d/.

Can also just check the logs to see what’s going on cat /var/log/Xorg.0.log or similar.


#23

Why reinstall? Why not just repair the boot loader from an USB stick with plain arch on it?


#24

For which post are you speaking of? The original reason for the re-install was that there wasn’t even a partition on my SSD after re-installing windows (which unfortunately, I have to have for work). The whole partition was undefined.


#25

I’m assuming that this is tty1. And no response to keyboard.


#26

Okay, I went to fallback on grub, and everything is working. I’m totally mystified.


#27

The Linux s mysteries, sometimes their s nothing to understand.


#28

Why did Windows need to be reinstalled in the first place?

What’s the configuration of this dual boot, single hard drive?


#29

OK. Sorry. My mistake.


#30

I have two HDDs at 2TB each and a 1TB SSD which is where AL resides. Windows was reinstalled from a backup. Which also reinstalled Linux Mint as well when I used Acronis. Windows was too corrupted from an update and therefore trashed it. If I didn’t need Windows, it would not be on my machine. Next time, hopefully there won’t be, I’m going to unplug the SSD before doing a Windows recovery.


#31

That’s okay, usually I would use tty or a live USB to work from. But in this case, AL was wiped and the partitions deleted.


#32

So you selected the wrong partition when using the Windows installer?

I’ve installed Windows after Arch a few times and it always left the non-targeted partitions alone (but it did nuke the bootloader).


#33

Not necessarily. I dual boot and I’ve had Windows take all available hard drive space even though I went through the custom install. Some sites actually recommend the user disconnect the hard drive for/with Linux when installing Windows on a dual boot setup.


#34

No, apparently when backing up the computer I have forgotten that at time I didn’t have the SSD. So, the rest was history. I will next time unhook the SSD or if I backup the whole computer so that this will not happen again. When installing any OS, I tripple check the partitions I’m using and unhook all other drives.


#35

Seems like a driver/gpu issue to me, what gpu?

If it’s a newer Nvidia (900 series or later) then you probably need to disable mode setting or something for nouveau, see here https://wiki.archlinux.org/index.php/Nouveau and make sure to check the troubleshooting section.

Regardless, it’s completely broken and without something more to go off I can’t offer anything helpful.


#36

My gpu is an older model. But, I was able to get to the desktop and lightdm is working. The driver has been updating regularly. Journalctl isn’t showing anything to give a clue as to why one moment there’s a black screen then the next no issue with the screen. The nvidia-340xx has updated everytime the kernel updated. All I can do is shrug my shoulders and scratching my head.