Failed to start session


#1

I’m stumped. I had to re-install AL because it got wiped out when windows had to be re-installed. Anyway, I finally got lightdm to finally come up. But, when I entered my password, I get a ‘failed to start session’ error. I tried looking up solution, even in the dreaded Arch forum, and I couldn’t find a solution. I’m wondering if perhaps the DE/WM got hosed. Any ideas?


#2

That sux mate, do you have lightdm-gtk3-greeter installed also ! On OpenBox , I3 .

Wonder if you re on XFCE also.


#3

Also, what video card do you have, might have to do with it.


#4

If you stop the lightdm service, can you log in and start an X-session from the console?

You cant try:

whereis <name of window manager>

in the console to see if the binary exists.

Which window manager?


#5

I’m using lightdm-gtk with openbox. Also, have gnome as secondary manager. Doing Whereis openbox just shows ‘openbox:’ as output. Same result with gnome.
This is why I’m thinking that both DM/WMs are either hosed, or for some reason, was never installed. I’m able to get tty2 but not tty1. This is the third time today I tried to install AL. With the same results.


#6

Might be a corrupt iso . Was that one that you installed AL with in the past !

That sux, 3rd attempt.


#7

I have tried it with and without Nvidia drivers. I’m also using the same iso as the last time I had installed AL. My bet is that the DM/WMs for some reason didn’t install on my SSD.


#8

Must have to do with M$ again, too bad that you had to reinstall AL.

Wonder why it didn t installed DM/WM this time around. Bet that you choose them at install time.


#9

The binaries are there; maybe openbox-session didn’t install. I think gnome has a simialr gnome-session script. Those are the files called to start the respective session.

You can try starting just openbox or gnome; either from the console or creating a *.desktop file in /usr/share/xsessions.


#10

Some gnome &/or openbox dependencies also might not have been installed somehow.


#11

Did gdm install with gnome? Maybe stop (uninstall) lightdm and try gdm.


#12

I got it guys! I reinstalled openbox and gnome. Then installed ob-autostart and obapps. That was certainly the strangest occurrence I ever ran into. But how that happened… :thinking::roll_eyes:


#13

Is it working now @sevenday4

Edit: Still with LightDM !


#14

Now I have to reinstall tint2, polybar, and everything else. Oh brother!!


#15

Gee, not an easy ride right @sevenday4 !


#16

Anyone know where I can get AL’s apps? the AL wall comes up, but everything else is gone.


#17

I’ll try your idea later incase I can’t get AL setup on this new WM/DM. What a crazy ride!


#18

Well, I tried to just install AL with openbox and just goes into tty1. I don’t know what to do except use another iso…


#19

You using the most recent iso (christmas)?


#20

I’m re-downloading the iso. I’m thinking that the iso I had isn’t working correctly. But, I think the iso I was using was 2019, but don’t know the version. If my plan works, then good, if not…