Failed to start Remount Root and Kernel File Systems

At booting time I’ll get this error. The system always recovers somehow and continues booting into openbox without further issues. But how shall I solve this problem which looks pretty dangerous?

root@archlabs /home/semo # systemctl status systemd-remount-fs.service     
● systemd-remount-fs.service - Remount Root and Kernel File Systems
   Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static; vendor preset>
   Active: failed (Result: exit-code) since Thu 2018-03-15 10:50:06 CET; 11min ago
 Docs: man:systemd-remount-fs.service(8)
       https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
  Process: 324 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)
 Main PID: 324 (code=exited, status=1/FAILURE)

Mär 15 10:50:08 archlabs systemd-remount-fs[324]: mount: /: Einhängepunkt ist noch nicht ein>
Mär 15 10:50:06 archlabs systemd[1]: Starting Remount Root and Kernel File Systems...
Mär 15 10:50:06 archlabs systemd-remount-fs[324]: /usr/bin/mount for / exited with exit stat>
Mär 15 10:50:06 archlabs systemd[1]: systemd-remount-fs.service: Main process exited, code=e>
Mär 15 10:50:06 archlabs systemd[1]: systemd-remount-fs.service: Failed with result 'exit-co>
Mär 15 10:50:06 archlabs systemd[1]: Failed to start Remount Root and Kernel File Systems.

I included an image from my screen:

How did you install your archlabs, with uefi or without?
You can post yours:
#parted -l
lsblk -a

1 Like

I guess I installed it with UEFI but I am not sure, since I can’t recall it.

Modell: ATA HGST HTXXXXX (scsi)
Festplatte /dev/sda: 1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer Anfang Ende Größe Dateisystem Name Flags
1 1049kB 538MB 537MB fat32 boot, esp
2 538MB 1000GB 1000GB ext4
#######
lsblk -a
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 931,5G 0 disk
├─sda1 8:1 0 512M 0 part /boot/efi
└─sda2 8:2 0 931G 0 part /
sr0 11:0 1 1024M 0 rom

it seems to have nothing.
I would try to do a chrot and reinstall the grub, with the partizoni maintained in:
/ Boot / efi
/ root
and see if the boot is restored.
off topic

Ps)ah I forgot the root, I think it’s too big, I would make it smaller.

Steps done:

  • Resizing / with parted from 1TB to some 200GB.
  • Reinstall of GRUB: sudo grub-install /dev/sda
  • Update of the GRUB configuration: sudo grub-mkconfig -o /boot/grub/grub.cfg

Result:
No errors while running the commands.

But after reboot the initially mentioned fail persists. Have you or has anyone further advice, please?

Please post the answers following commands
cat /etc/fstab
mount
#blkid

fstab:

/dev/sda2

UUID=fe77535b-beb0-4ed3-98ff-57070ac29efd / ext4 rw,noatime,nodelalloc,data=journal 0 1

/dev/sda1

UUID=1F00-06F1 /boot/efi vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 2

/swapfile none swap defaults,pri=-2 0 0

mount:

proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=8159488k,nr_inodes=2039872,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda2 on / type ext4 (rw,relatime,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=36,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=2632)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1633048k,mode=700,uid=1000,gid=985)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=985)
jetbrains-toolbox on /tmp/.mount_jeZeU0 type fuse.jetbrains-toolbox (ro,nosuid,nodev,relatime,user_id=1000,group_id=985)
/dev/sdb1 on /run/media/semo/FD-SETUP type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=985,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
/dev/sda3 on /run/media/semo/more storage type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)

blkid

/dev/sda1: UUID="1F00-06F1" TYPE="vfat" PARTUUID="159eb0ac-4a14-423e-b5ab-8e0a1f06e99e"
/dev/sda2: UUID="fe77535b-beb0-4ed3-98ff-57070ac29efd" TYPE="ext4" PARTUUID="995566fd-88de-41a4-9fef-93f117b98a14"
/dev/sda3: LABEL="more storage" UUID="4d56f440-cbf7-449b-9a2e-ccd610137494" TYPE="ext4" PARTLABEL="storage" PARTUUID="8d7728a6-f84f-4ca4-ba81-55706f648058"
/dev/sdb1: SEC_TYPE="msdos" LABEL="FD-SETUP" UUID="191F-101A" TYPE="vfat"

There is a big chaos in your fstab.
Make a copy of your fstab and give the following command,
#genfstab -U /mnt >> /mnt/etc/fstab
and place the fstab.

Sorry, are you sure with the command? Could you explain what I will achieve with it? There is no directory /mnt/etc/fstab… Should I create it first?

EDIT: I created it, But the Terminal says /mnt is not a mountpoint. I think it’s / on my system…
EDIT 2: I resolved it with genfstab -U / >> /mnt/etc/fstab There was a new file afterwards. Shall I overwrite the file in my system at location /etc?

Sorry, but your fstab is fine, I read from the phone and I did not have glasses the strange thing blkid!
forgive me :cry:

Can we please see the full output of

LC_ALL=C journalctl -u systemd-remount-fs.service --no-pager --since=today

Thanks!

@ector Fine. I am happy to hear that. :smile:

@Head_on_a_Stick of course. :slight_smile:

-- Logs begin at Mon 2018-03-12 09:03:20 CET, end at Sat 2018-03-17 09:51:36 CET. --
Mar 17 09:50:17 archlabs systemd-remount-fs[212]: mount: /: Einhängepunkt ist noch nicht eingehängt oder es wurden ungültige Optionen angegeben.
Mar 17 09:50:17 archlabs systemd-remount-fs[212]: /usr/bin/mount for / exited with exit status 32.
Mar 17 09:50:17 archlabs systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Mar 17 09:50:17 archlabs systemd[1]: systemd-remount-fs.service: Failed with result 'exit-code'.
Mar 17 09:50:17 archlabs systemd[1]: Failed to start Remount Root and Kernel File Systems.
Mar 17 09:50:22 archlabs systemd[1]: Starting Remount Root and Kernel File Systems...
Mar 17 09:50:22 archlabs systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Mar 17 09:50:22 archlabs systemd[1]: systemd-remount-fs.service: Failed with result 'exit-code'.
Mar 17 09:50:22 archlabs systemd[1]: Failed to start Remount Root and Kernel File Systems.
1 Like

Remove the data=journal parameter.

https://bbs.archlinux.org/viewtopic.php?id=153984

1 Like

This looks like an error in the installer so I have opened a PR that should correct it (I hope):

https://github.com/ARCHLabs/Installer/pull/3

2 Likes

Thank you again. Just to be sure, should I remove everything of the string --> “, data= journal 0 1” ?
Isn’t journalling the filesystem an integral part of modern Computer Systems? Have you got a pointer for me, why the parameter isn’t required in ext4 or rather ext3? Is Archlab Linux already journalling the filesystem?
Best regards,
semo

EDIT: added ext4 vs ext3 to question, removed bad grammar

just this
data= journal

1 Like

Yes, journaling is applied automagically for ext4, those data= options are just for ext3 and are the source of the errors (according to the linked Arch forums thread).

It would be very helpful if you could try removing the option from your /etc/fstab and report back on whether this fixes things for you, thanks!

EDIT: that noatime option is pretty pointless (and it breaks mutt), relatime has been the default for ext4 since kernel 2.6.20 and is quite sufficient; modern SSDs do not need such special treatment any more anyway.

1 Like

Oh, excuse me, I marked the solution of yours. I changed the option yonder. All went well, after reboot and the error was gone. You were right with your conjecture, that the error has something to do with the installer, where I selected the option to journal the filesystem. :grin:

Ah yes, I see that now, I’m not familiar with this new-fangled discourse and was expecting an old-fashioned [SOLVED] :smiley:

Thanks for the feedback, this report should help improve the ArchLabs installer for everybody.

ArchLabsMinimo installer still suggests using noatime.

edit: as suggest, removing noatime, and data= from fstab, still get several failed to remount/unmount oldroot messages:

_# /dev/sdb2
UUID=5a29f7ca-3259-425f-add5-47ee5785ad29 / ext4 rw 0 1
_# /dev/sdb1
UUID=d4d38005-992c-4b41-ae8a-ab290a63924f none swap defaults,pri=-2 0 0