Failed Light manager


#1

Hello guys… Iv been using Al for a while now and everything was fine. Last night I booted my system and there was nothing but a black screen I used ctrl+alt+f2 to get to the terminal and tried to update and do other stuff that was mentioned in some similar issues by others on the forum. But nothing worked yet. What might be wrong?


#2

Probably same issue as this.

https://forum.archlabslinux.com/t/lightdm-fails-to-start-solved/2821/4


#3

It is showing that I have no access.


#4

During the last system update you installed the 1:1.28.0-2 lightdm version, which was broken. You just need tu update:

pacman -Syu

and restart.


#5

I am not able to update using the above command.


#6

try
sudo pacman -Sc or Scc
sudo pacman - Syu
reboot


#7

Either you don’t have an internet connection at all or you can’t resolve URLs.

Check with:

ping 8.8.8.8

^ If that works then try

sudo tee /etc/resolv.conf <<<"nameserver 8.8.8.8"
sudo pacman -Syu

If the ping command doesn’t work then you don’t have an internet connection at all.

To connect with a plain ethernet cable (non-wireless) then use

systemctl start dhcpcd

To connect with wireless try

nmcli device wifi connect "$ssid" "$password"

^ Replace $ssid with the actual name of the access point and replace $password with the actual password.

Once connected then try an update again:

pacman -Syu

#8

I am not able to connect to Internet via LAN. Using above command


#9

What if you run dhcpcd as root? Any error messages?

Please don’t post another screenshot, if you need to post console output then use a pastebin client:

https://wiki.archlinux.org/index.php/List_of_applications#Pastebin_clients