Extending laptop screen to vga

Hello,
I use a Lenovo Thinkpad 530 and archlabs/Windows 10 in Dualboot. I want to extend the screen to VGA. In Windows this works.
In archlabs I use openbox and lightdm.
I try xrandr and there is no monitor recocgnized: any Idea what I missed?
➜ ~ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
1920x1080 60.00*+ 59.93 50.00
1680x1050 59.88
1400x1050 59.98
1600x900 60.00 59.95 59.82
1280x1024 60.02
1400x900 59.96 59.88
1280x960 60.00
1368x768 60.00 59.88 59.85
1280x800 59.81 59.91
1280x720 59.86 60.00 59.74
1024x768 60.00
1024x576 60.00 59.90 59.82
960x540 60.00 59.63 59.82
800x600 60.32 56.25
864x486 60.00 59.92 59.57
640x480 59.94
720x405 59.51 60.00 58.99
640x360 59.84 59.32 60.00
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

What is your video hardware & driver?

lspci -knn | grep -iA3 'vga\|display\|3d'
1 Like
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
    Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
    Kernel driver in use: i915
    Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K1000M] [10de:0ffc] (rev a1)
    Subsystem: Lenovo GK107GLM [Quadro K1000M] [17aa:21f5]
    Kernel modules: nouveau, nvidia_drm, nvidia
01:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio Controller [10de:0e1b] (rev a1)

Looks like an Optimus system, have you tried Bumblebee or PRIME? I’ve never owned a system with a discrete GPU but you might have to use the NVIDIA card for an external display.

If you wait a bit somebody with experience of such devices may be able to offer better advice.

Ok thanks, i’ve installed bumblebee but i’m not shure how exactly to use it.
I tried it with following wiki
https://wiki.archlinux.org/index.php/Bumblebee#Output_wired_to_the_NVIDIA_chip

I followed the steps of creation/edit of 20-intel.conf and xorg.conf.nvidia

That makes two of us :grin:

It’s probably best for you to post the exact command(s) you have used rather than just linking to a wiki page, also provide the full content of any configuration files and any errors.

So no it works but i didnt change anything between the trys.
I put in the following command:
optirun intel-virtual-output
/usr/bin/vglrun: Zeile 191: hostname: Kommando nicht gefunden (command not found)

maybe its because i used the dockingstation now; i’m not shure if I tried it before with it.