Every time I login, I see a grey background for a second. How to fix it?

Hi :slight_smile:

It’s just an annoyance, but I’m trying to find out what is causing it. I commented out this line in .xprofile

#nitrogen --restore &

For some reason it was showing AL gray wallpaper before loading my own wallpaper folder, even though I removed the default wallpapers it started to show a solid grey color.

I’m also using sddm, but I’ve seen this issue before even with lightdm I think. I have set my wallpaper folder via “desktop settings” / right click. Is this issue stuck in some xfce config?

Which window manager are you using?

1 Like

I’ve seen this with Openbox, a flash of the default wallpaper before switching to the one I selected.

I think @Sorcerer is also using openbox and seeing this.

To fix it, cd to /usr/lib/openbox

Should have the openbox-autostart file.

As root, use your favorite text editor and comment out the top section that sets the background color to #303030 (which happens to be a nice shade of gray).

That will prevent openbox from setting a background prior to reading ~/.config/openbox/autostart, but preserve all the other openbox session features.

1 Like

I am using xfce4 here

Makes sense as OpenBox uses some XFCE dependencies as well.

Is that after some updates or else.

Might have found the issue, but haven’t taken any action yet xD trying to figure out an non-gui approach to correct it.

Ok the file is here… /home/user/.config/xfce4/xfconf/xfce-perchannel-xml/ well, I’m backing it up and trying to erase those workspace specific (I think) backgrounds – apparently this didn’t help :frowning: after logging out / in the old settings still are in place, probably elsewhere than the .config folder

Edit2: For science, I went ahead and deleted all those entries (monitor0, workspace0-workspace3) on the screenshot, with reset button in the GUI tool. It did affect, that it removed also my current wallpaper. But anyway :sob: none of it fixed the gray solid background upon login - I even rebooted to see if it is gone, nope.

The gray solid background which shows for 1 sec upon login, is what I am trying to find XD!

Try this,

$ rm ~/.cache/sessions/* && chmod 500 ~/.cache/sessions

Do you set a background image in your sddm/lightdm? It may help.

sddm:

/usr/share/sddm/themes/theme_name/theme.conf.user

[General] 
background=/path/to/background_image

lightdm:

In your greeter's config,

background = /path/to/background_image

An actual wallpaper with the AL branding or just a gray color?

Check your xfce start up files. Are you also running something like nitrogen or feh?

Tried everything you guys wrote, well in fact I changed my sddm background to something else now. Also I did sudo pacman -Rsn feh nitrogen - it looks like this is not caused by these. I’m just using the default software installed by AL. @PackRat yes before it would display the AL branded background, but since I deleted them it started to display this grey instead, and if you are asking me which bg - it was the mountains :slight_smile:

And yeah as I mentioned and also SqdbGunny (poster above) I’ve seen this before, I mean years before xD never figured out where it’s coming from, but this time I’m trying to because I’m bored and just ricing random stuff :slight_smile:

Now that I changed my background of sddm, I “technically” have 3 backgrounds (if we count this solid grey, which displays in the middle for 1-2 seconds after logging in).

sddm background → solid grey → actual desktop background


I don’t exactly recall seeing this last time when I was using lightdm, but maybe I wasn’t trying to rice last time either. Maybe this is part of xfce4 system theme? I am going to change it and see if it at least changes the solid color to anything else xD apparently not, I changed to Adwaita theme which is white, and rebooted but the grey background is still there.

This is what it looks like, I was able to screenshot it while logging in (the grey solid bg, before my actual desktop bg takes into effect a second later)

Color: #808080

1 Like

You using xfce4 compositor? Turn it off and then try logging in.

### Bug Description

If the built-in compositor is enabled, xfwm4 will draw a plain grey background over the lightdm greeter background on session login. As soon as xfdesktop starts the initial background image gets restored. This transition should be improved to eliminate the visual flicker during the session login.

xfce4 bug report

Based on some other forum posts, this bug has been around for several years and has not been completely squashed.

2 Likes

Does that means that one has to disable the compositor !

Wow, like 9 yr bug, they re quick to fix it !

Only to get rid of the gray flash. If there is a way to set that background to black, it probably wouldn’t be so bad. Might be a line in xfce4-startup (whatever the xfce4 startup file is) that sets that desktop color.

2 Likes

Ah, thx for the explanations in there @PackRat

That explains everything. It’s almost like an dead end, but now at least everyone who has seen the solid grey color - will know why that is so :smiley: and I’m here wondering “how’d you even find info on this stuff!?”

I’m using 99.90% AL defaults for my configs, so the default compositor is called Picom (for Xfce4 install)

~/.xprofile

# start the compositor (transparency, fade, shadows, blur, etc.)
picom -b &

Yep I disabled it, just to see if the grey is gone. The grey is gone, and now I have pure void of blackness instead of the grey XD doesn’t sound like a fair tradeoff to me to disable the compositor so I that don’t see the grey.

The reason I kept seeing the AL branded WP of mountains (between my newly found colorful/cheerful plasma bgs) was because of this:

~/.xprofile

# restore the last wallpaper applied with nitrogen
nitrogen --restore &

So if you find yourself annoyed you gotta check here:
~/.config/nitrogen/bg-saved.cfg

I tested it, and I couldn’t get this config to work:

file=~/Pictures/wallpapers/plasma/Xero-Plasma1.png
## And this example didn't work either:
file=/home/user/Pictures/wallpapers/plasma/Xero-Plasma1.png

But this one works, gotta create an new folder in /usr/share/backgrounds and place your “1-2 second dummy background” in that folder:

file=/usr/share/backgrounds/plasma/Xero-Plasma1.png

There is still 1 tiny compositor side effect, it blinks (but with the right background this time) :stuck_out_tongue: but it is what it is, you can disable compositor to get rid of this blink. But if you know why it is happening, it might not be an issue for you any longer xD

Thank you @PackRat for finding the root of this issue :slight_smile: feeling in peace!

1 Like

Glad that it s fixed @Sorcerer , props to @PackRat

1 Like

You’re using picom as the compositor for xfce4?

Disable that line in your ~/.xprofile then go into the xfce4 settings “Window Manager Tweaks” and enable xfce4 native compositor.

The bug fix for the gray screen was for the xfce4 compositor, not picom which is a stand alone program.

If you are using other window managers like openbox, enable picom in the ~/.config/openbox/autostart file for compositing in openbox. Try and keep your xfce4 DE as separate as possible from the window managers.

2 Likes

Didn’t knew that, this entire time I assumed whatever is in my .xprofile after an fresh AL install (whatever de/wm I am picking)- is “meant to be used” the way it ships with xD so apparently I had 2 compositors running in the same time because I just saw Xfce4 had it already enabled too. And god knows for how long :slight_smile: (ever since I stopped actively installing base arch, probably cause I remember always using compiz or something back then haha)

My understanding was that if I select “Xfce4 desktop” during install process, then the .xprofile + some other configs will be tailored for Xfce4 specifically. This is good info though, added into my notes!

1 Like

Sometimes they are but maybe some missed stuff, did you install XFCE4 as the only desktop?

It’s a late reply, but yes :slight_smile: via the AL bootstrap installer I only choose 1 DE/WM at a time when it’s time for a reinstall (today is that day again xD). I’m not sure, but Picom might be ready enabled there for something like Openbox? I don’t think there have been any bad side effects for me because I ran Xfce composite + Picom in the same time for a long time xd maybe there were/are issues but I haven’t been aware.

However if you ppl ever decide to change/improve this “theme-specific config stuff”, then great it’s luxury and it would mean it’s 1 less line to manually config after an fresh install example for Xfce4 (or any) users xD I can personally live without it, but I like surprises too :stuck_out_tongue: !

1 Like