Esc-key not working

I have 2 (old) laptops that I am installing AL on.
Dell Latitude E6430 (Openbox)
Hp ProBook 640 g1 (gnome and i3-gaps)

The problem is on HP! The esc-key seems to be out.
It seems to be just the esc-key that is “dead” (or sleeping).

How do I test this?
Language is set to se and sv_SE.UTF8
Could it be keyboard-model?

womp

My Dell’s have a lock Fn key. Is your set to Locked? If so then Fn works as the dominant key function.

How do I check that?
It is the Hp probook that has the problem. It does not seem to hw because I can get in to bios and boot-manager with esc-key!
I did an arch-vanilla install with xfce and the same problem there. Locale is set right but I tried different xkb-models but nothing changes!
I have a vague memory that I have been through this before with hp pb but can’t remember what I did to fix it!

womp

To see if they are locked hit a function key (say F1) and see if you get F1 (generally a menu) or if you get the function on my current laptop that is sound mute. I use the Fn key (bottom row) and Esc to toogle the Fn lock function in the top row.

1 Like

Open a terminal and run xev

xev

A white box will pop up. Press your ESC key and see what value is returned in the terminal.

So the ESC key doesn’t stop functioning until you’re booted into Arch?

What where you trying to do in Arch when you discovered the ESC key wasn’t functioning?

1 Like

Hi!
Did a reinstall with Archlabs instead. xev and pressing esc gives nothing!
The strange thing is that during install esc worked!?

womp

Hi again! I got xev to “react” to esc-key.
If I press fn-key and release fn-key and then press esc I got this:

"KeyPress event, serial 48, synthetic NO, window 0x3c00001,
root 0x139, subw 0x0, time 7426794, (162,-209), root:(163,380),
state 0x0, keycode 9 (keysym 0xff1b, Escape), same_screen YES,
XLookupString gives 1 bytes: (1b) "
mbLookupString gives 1 bytes: (1b) "
FilterEvent returns: False

KeyRelease event, serial 48, synthetic NO, window 0x3c00001,
root 0x139, subw 0x0, time 7427160, (162,-209), root:(163,380),
state 0x0, keycode 9 (keysym 0xff1b, Escape), same_screen YES,
XLookupString gives 1 bytes: (1b) "
FilterEvent returns: False"

That must mean that it works!?

Manyroads: You were absolutely right it had to do with fn-key!

womp

Just a lucky guess… happens to me a lot. I have fat fingers, I guess.

1 Like

Ha ha! Yeah you must have fat fingers!

And here it comes:
Now I can use esc-key but only if I press fn-key first!
It must be possible to change that!?
What do you do on your Dell to make it “stick”?

womp

Hi again!
I figured it out. (with little-fingers!)

It was in bios! Before I installed AL I was looking in bios to make sure it was set to uefi-boot!
Must have changed the fn-key option there because now it is solved.
Thank you for support!!
It was because of your (fat fingers) understanding of how computer hardware works!

womp

1 Like