Errors on installation. iwlwifi: Microcode SW error detected

I am trying to install ArchLabs 2019.10.29. On installation, right after booting the terminal, multiple errors appear (photo is below).
After running archlabs-installer, when trying to connect to wi-fi, it quits and says that there is no connection. On one try, there was the connection and the installer proceeded, but the errors continued to appear which made the installation process unbearable. I tried to solve by manually connecting to wi-fi but the main problem is error messages, they appear almost every 5 seconds randomly, and they destroy the commands syntax, so I need to type commands agains and also have a risk to type something undesirable.

So, I have 2 main problems:

  1. I need to somehow stop error messages from appearing because they really disturb.
  2. I need to fix these errors because, you know. They are errors.

I am comepletely new in Linux but I googled the problem, and seems it’s a common one, but it’s different from case to case and most often the desicion is about the OS which is already installed which is not my case. There are some ideas:

  1. It’s said, that you can silent errors by typing [command] 2> /dev/null but the problem is I don’t know which command initiates these errors. Tried iwlwifi, doesn’t work. Also, I want to know the way to call error messages back when the problem is fixed but probably it’s [command] 2> stdout or something, haven’t googled yet.
  2. There is a decision with installing Intel driver iwlwifi-9260 to /lib/firmware but it works if you already have the linux system installed, and I have only the boot environment so I am not completly sure how to install files there before the partitions are created. Probably I should download them to my NTFS partition and try to read them from there but I am not sure ntfs-3g is present and first I need to silent the error messages.
    Also there is an option of adding
    options iwlwifi swcrypto=0 bt_coex_active=0 power_save=0
    But again, I am not sure how it works in boot environment, and I don’t completely understand what this thing is actually about.

However, I will try different methods, but I decided to open a topic on the problem, so here we are.

upd.: JIC. The firmware is UEFI, wi-fi adapter is intel Dual Band Wireless-AC 3168. Booting from CD.

Tried to silent messages with sh 2>&1, and that just changed the first word from archlabs to sh-5.0. Errors continued to show.
upd.: Also I realised it’s useless to mess with files because I boot from CD-R.

Tried to connect to wi-fi with wifi-menu, entered the name of the network and the password, and the terminal answered with “connection failed”. But on Windows, I connect to wi-fi freely.
ifconfig screen is below.

The error messages are from stderr and do not affect stdin so you can carry on typing and just ignore them.

They’re from the kernel, run this command to silence them:

sysctl -w kernel.printk="0 0 0 0"

The ISO already has that firmware and anyway it isn’t loaded for your hardware.

The swcrypto & power_save options are set to 0 (or N for the latter) by default.

Try pressing e with the installer boot menu entry highlighted (or use <tab> if you’re booting in non-UEFI mode) then add this to the end of the line that starts with linux and press <ctrl>+x (or <return> for non-UEFI) to boot the modified entry:

iwlwifi.swcrypto=1 iwlwifi.bt_coex_active=0

You may only need one of those. Or maybe neither will help.

Do you see this problem with other distributions? Perhaps your hardware is failing.

Was that the only message?

For wifi-menu to work the interface must be set down beforehand:

ip link set wlp2s0 down

I haven’t tried other linux distros but with windows, my wi-fi works great. Does all that mean that my hardware is not fully suported by linux drivers? Though I know the connection itself would work cause it did.
In this case, will there always be these errors even after the install and should I always silence the kernel? This sounds incovinient.
Sorry for stupid questions but I really want to get all this.

UPD.: I’ve found that there is a linux driver for my wi-fi adapter. It’s iwlwifi-3168-ucode-22.361476.0. Probably it doesn’t exist in the ISO, and I need just to install it after installation of the OS?
UPD2.: No, as I’ve checked, this firmware also exists in the ISO, so the problem is about something else.

Besides those error messages about iwlwifi, yes. And you are right, wlp2s0 was set to “up”.
I will try all the recomendations and write back what I got, thanks.

I want to make sure that I’ve done things right beacuse this didn’t work.
There were no lines that start with linux, actually only one line which included several options started with initrd and one option with archisobasedir.
Then i just added iwlwifi.swcrypto=1 and iwlwifi.bt_coex_active=0 at the end of the line after spaces. I also tried iwlwifi.11n_disable=1 after that just in case.
Despite having UEFI loader, <ctrl>+x did nothing, so after <ctrl>+x I just pressed Enter.

Regarding the rest, it worked, but I am still concerned about the problem appearing on the installed system.

No, Linux should support that well. The Intel wireless drivers are open source and from Intel themselves and they are a Platinum member of the Linux Foundation.

I presume your wireless device does actually work in the installer?

Yes, sorry, I forgot that Arch-based images use systemd-boot for UEFI systems instead of GRUB.

Yes, I’ve checked it with ping on But if kernel.printk="0 0 0 0" is not set as you said, error messages continue to appear so I’m gonna need to do something with them in the system.

Add the setting to /etc/sysctl.conf.d/local.conf to make it permanent.

Probably best to check the default first then use whatever is returned in the configuration file but change the first number to 0.

For example from my Debian box:

empty@E485 ~ % sysctl kernel.printk
kernel.printk = 4       4       1       7
empty@E485 ~ %

So I would enter this line:

kernel.printk=0 4 1 7

See also

1 Like

That looks useful, I’ll try it.
However, I would be glad to do it more proper way with solving the bug, not just silencing the kernel. I found a way with using different firmware versions, but if it doesn’t work, there seems to be only the suggested way.

I tried archlabs-2020.03.02-beta and I have some important remarks!
First, there were no error with iwlwifi!
Second, I wasn’t able to connect to my wi-fi. If the adapter, which happened to be wlan0 this time, is down, wifi-menu responds with “no networks found”. When it’s up, it sees networks but after inserting the password, the installer says ‘connection failed’ as before.
So I don’t know how to connect to wi-fi with the new iso, I want to try it.