Errors installing ArchLabs on VM

I am getting some errors while installing ArchLabs when installing on VirtualBox using the efi option.


I am using Pacstrap to install.

I have selected the grub bootloader.

I am deciding to install openbox and xfce4.

For my loggin manager I am using ssdm
image

For additional packages I am installing alacritty, firefox, htop and gparted

This is my configuration. So basically I am setting up a dual boot between Windows 10 and ArchLabs. On the last partition I created a luks encrypted container and inside the container I created an lvm partition and have 3 partitions inside of it. The partitions are mounted as /, /home and /swap. For my /boot partition I have formatted the Windows boot partition and mounted it as the /boot.

Here are all the error messages that I got along the way (I pressed continue its fixed as I have no idea how to fix these errors:


I am not too sure if I am doing something wrong or something?

Update archlabs-installer. Pacman -S archlabs-installer. After update it will be renamed installer. Just installer without archlabs- . You can take a note of installer version it should be higher one.

I will give that a shot. But why does the current installer have issues though out of curiosity I ask?

Probably there was some changes with archlinux it self.

2 Likes

Thank you 3O0QUI1O for the solution. It worked on the Hyper-V VM that I was testing on. I was coming back here to mark your answer as the solution but it doesn’t seem to allow me (makes sense, likely OP has to do so.)

Again for all to see

pacman -S archlabs-installer

Then run

installer

And you’ll be running in no time.

I just want to confirm trying to install QEMU results in the exact same error.

Hey @hikingrory, welcome to the forums!

@unix_lover if you’re still having trouble, I would try using the regular BIOS option instead of an efi option.

-boot into the USB in LEGACY mode
-If your virtual drive is already split into 2 partitions, run these two commands before running archlabs-installer:

mkfs.vfat -F32 /dev/sda1
mkfs.ext4 -q /dev/sda2

remember to replace the above labeled partitions with your actual partitions
Now run archlabs-installer
-once you reach the main menu, skip down to option 4.1 “mount partitions” and follow the instructions to reformat your GRUB and ROOT partitions. Do NOT reformat your partitions using option 2 in the main menu.
-continue as normal

Thank you, I’ll give it a shot when I get a chance to get back to it. I don’t have a lot of time. It might have to just sit a while. I wanted to see for myself what Arch is all about, but it may take up more time than I have to spare. If so, at least I will know.

I’m not using a USB. I’m trying to set it up in QEMU from an ISO on my hard drive.

I’ve tried QEMU and Virtualbox multiple ways from the downloaded ISO. Breaks at the same point as it did for unix_lover. I’m trying to run this inside Bunsenlabs lithium.