Error while installing ArchLabs on VirtualBox


#1

I tried to install ArchLabs (archlabs-2018.12.17.iso) on VirtualBox 6.0 twice and got an error during the actual installation:

ERROR: /bin/bash: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory

Is anyone aware of this problem? Did I anything wrong or is it a bug?


#2

I tried to install it in virtualbox to see and I had no luck too, graphical glitch appears, forced extinction, and grub recovery at reboot…


#3

try this:
I solved by not mounting my previous /var partition. It was causing all those problems.

if it does not work check if this package is described in this post

https://bugs.archlinux.org/task/51818


#4

I honestly wouldn’t mess with VB, if you paid me.


#5

Why? What do you use for your VMs?


#6

OP made me want to try again, this time in vmware

2019-01-09_14-49

This is interesting, during the install it said that it couldn’t detect root, and in the middle of the process many things had failed to install
Also grub is here (that was not the case with virtualbox) but it won’t detect the UUID of the virtual disk at reboot.
I’m not good enough to use Qemu, if someone wants to try…

PS: This is not a call for help, I just wanted to share an experiment, maybe it could be interesting for the dev.

Edit:
This time I don’t use automatic partitionning
I’m now manually trying with a full /
No /boot or else
2019-01-09_16-12
Error: Installation for i386-pc platform
Installation finished, without error (uh?)
Option “–target=i386-pc” not recognized
hum ok let’s what happens just after that.
no reboot or anything, it says that these /tmp/ai are deleted
2019-01-09_16-17
I try a reboot, grub-rescue

Last Edit: Trying with Clover OS so you can see I’m not totally in fault, it (vmware) works.

I stop trying (had enough fun), you can try from your side.


#7

I’ll have a look at it, seems the readline object file is out of date causing linkage issues. Well likely have another iso refresh with a few small fixes.


#8

Also there is no problem on a real machine, it works fine. That’s the weird point.


#9

I like your way of thinking and working. Really appreciate your experiments!


#10

Looking forward!


#11

Ah, that’s weird. I’m at work for another few hours but once home I’ll see if I can figure out what’s going wrong.


#12

Yeah. Been having this issue all day on both of my machines. VMWare Fusion and Workstation, both having the same "Error: device ‘’ not found. Skipping fsck. can’t find UUID’ issue. Tried everything over multiple installs and cant get it to work in a vm.


#13

It reassures me, I had the impression to have missed something or to have messed up with the partitionning
@kenokenobingo that’s just autism lel, I pretend more than I know.
@natemaia good courage to you


#14

The 2019 release works for me, you have resolved the bug. Well played.