ERROR: resume: no device specified for hibernation

Hello, mates.


Today I reinstalled Archlabs and I’m having a problem.
ERROR: resume: no device specified for hibernation
But I created a swapfile as always I make.
How to solve this problem, please?

Check the ArchWiki entries for swap and hibernation. I believe the fix is documented in one of those.

1 Like

I read it before, but I could not find the solution for swapfiles.
The swapfile was created on installation and I followed the instructions on archwiki to ‘activate’ it but nothing, then I decided to reinstall the OS without swap partitions or files.


Thanks

I think it’s in the Required kernel parameters section.

2 Likes

Sorry I’m kinda late on this.

We try to enable resume if the user picks swap (partition or file) and as far as I know it should work, it follows the arch wiki setup - installer script.

It seems like swap files are less supported than swap partitions but they’re both supposed to work, if you really want resume I can help getting it setup, you just need to post the output from

efibootmgr -v

free --mega

cat /etc/mkinitcpio.conf
1 Like

Appears to be the case. I was using a swap file and get the same error as @NewKommerInLinux even after following the ArchWiki again. Reconfigured with a swap partition and everything works now.

3 Likes

Haven’t used hibernation for years. Suspend to RAM is sufficient for me.

3 Likes