Error Formatting

Anyone else getting this error when trying to format a USB? As usual Google brings no help

2020-09-12-@17-20-02-scrot

I’m thinking it could be a bug with the latest 5.8.8 kernel but again I have found nothing to support that, just my thoughts as that is all that has changed on my system.

EDIT: Or the change from libsytemd to systemd-libs could be the culprit also.

Have you tried with gparted after a reboot?

Yeah, I have tried everything. I have a new 2TB drive I want to format :smiley: It’s all good, I’ll wait for the next kernel update.

Which command(s) are you using to attempt the format?

Have you tried downgrading the kernel package?

Initially I tried using the format function in Gnome Disks then I tried:

sudo mkfs.vfat /dev/sdi1

I considered doing that.

What was the error message from that?

Can we see

parted /dev/sdi print

So I tried again in gparted (formatted as NTFS) and I got a lot of pop ups (same as above) while formatting but seemed to have some success?

Model: Imation HQT (scsi)
Disk /dev/sdi: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.0GB  16.0GB  primary  ntfs

EDIT:
Tried again in the terminal with FAT format:

Model: Imation HQT (scsi)
Disk /dev/sdi: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.0GB  16.0GB  primary  fat32

EDIT2:
Just formatted the 2TB drive I got today with success. I don’t know what is going on with Gnome Disks and that error message.

Try clearing the device completely:

sgdisk --zap-all /dev/sdi
wipefs -a /dev/sdi
partprobe /dev/sdi

Then start again.

Good call, shall give that a shot very soon.

Interesting:

***************************************************************
> sudo sgdisk --zap-all /dev/sdi                                                                                  ~
[sudo] password for dobbie:

***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory.
***************************************************************


Warning! Secondary partition table overlaps the last partition by
33 blocks!
You will need to delete this partition or resize it in another utility.
> sudo wipefs -a /dev/sdi                                                                                  ~ RC=130
/dev/sdi: 2 bytes were erased at offset 0x000001fe (dos): 55 aa
/dev/sdi: calling ioctl to re-read partition table: Success
> sudo partprobe /dev/sdi                                                                                         ~
Error: Partition(s) 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64 on /dev/sdi have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.

Does the device show up in the output of findmnt?

No it doesn’t:

TARGET                                SOURCE     FSTYPE          OPTIONS
/                                     /dev/sdc2  ext4            rw,relatime
β”œβ”€/proc                               proc       proc            rw,nosuid,nodev,noexec,relatime
β”‚ └─/proc/sys/fs/binfmt_misc          systemd-1  autofs          rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=1341
β”œβ”€/sys                                sys        sysfs           rw,nosuid,nodev,noexec,relatime
β”‚ β”œβ”€/sys/kernel/security              securityfs securityfs      rw,nosuid,nodev,noexec,relatime
β”‚ β”œβ”€/sys/fs/cgroup                    tmpfs      tmpfs           ro,nosuid,nodev,noexec,size=4096k,nr_inodes=1024,mode=755
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/unified          cgroup2    cgroup2         rw,nosuid,nodev,noexec,relatime,nsdelegate
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/systemd          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,xattr,name=systemd
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/memory           cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,memory
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/cpuset           cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,cpuset
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/rdma             cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,rdma
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/net_cls,net_prio cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/freezer          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,freezer
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/pids             cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,pids
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/hugetlb          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,hugetlb
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/perf_event       cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,perf_event
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/cpu,cpuacct      cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
β”‚ β”‚ β”œβ”€/sys/fs/cgroup/blkio            cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,blkio
β”‚ β”‚ └─/sys/fs/cgroup/devices          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,devices
β”‚ β”œβ”€/sys/fs/pstore                    pstore     pstore          rw,nosuid,nodev,noexec,relatime
β”‚ β”œβ”€/sys/fs/bpf                       none       bpf             rw,nosuid,nodev,noexec,relatime,mode=700
β”‚ β”œβ”€/sys/kernel/debug                 debugfs    debugfs         rw,nosuid,nodev,noexec,relatime
β”‚ β”œβ”€/sys/kernel/tracing               tracefs    tracefs         rw,nosuid,nodev,noexec,relatime
β”‚ β”œβ”€/sys/kernel/config                configfs   configfs        rw,nosuid,nodev,noexec,relatime
β”‚ └─/sys/fs/fuse/connections          fusectl    fusectl         rw,nosuid,nodev,noexec,relatime
β”œβ”€/dev                                dev        devtmpfs        rw,nosuid,relatime,size=8163124k,nr_inodes=2040781,mode=755
β”‚ β”œβ”€/dev/shm                          tmpfs      tmpfs           rw,nosuid,nodev
β”‚ β”œβ”€/dev/pts                          devpts     devpts          rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
β”‚ β”œβ”€/dev/hugepages                    hugetlbfs  hugetlbfs       rw,relatime,pagesize=2M
β”‚ └─/dev/mqueue                       mqueue     mqueue          rw,nosuid,nodev,noexec,relatime
β”œβ”€/run                                run        tmpfs           rw,nosuid,nodev,relatime,mode=755
β”‚ β”œβ”€/run/media/dobbie/Music           /dev/sde1  ext4            rw,relatime,stripe=8191
β”‚ β”œβ”€/run/media/dobbie/M2              /dev/sdf1  fuseblk         rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096
β”‚ └─/run/user/1000                    tmpfs      tmpfs           rw,nosuid,nodev,relatime,size=1634540k,nr_inodes=408635,mode=700,uid=1000,gid=985
β”‚   └─/run/user/1000/gvfs             gvfsd-fuse fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=985
β”œβ”€/tmp                                tmpfs      tmpfs           rw,nosuid,nodev,size=8172712k,nr_inodes=409600
β”œβ”€/boot                               /dev/sdc1  ext4            rw,relatime
└─/home                               /dev/sda   ext4            rw,relatime

Also removing and plugging the USB drive in shows that the formatting didn’t work. It is in the same state as before.

Okay, unplug the drive and run

udevadm monitor

Then plug the drive in and post whatever new output appears in the terminal.

KERNEL[16498.696114] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9 (usb)
KERNEL[16498.701743] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0 (usb)
KERNEL[16498.702298] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8 (scsi)
KERNEL[16498.702379] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/scsi_host/host8 (scsi_host)
KERNEL[16498.702497] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0 (usb)
KERNEL[16498.702602] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9 (usb)
UDEV  [16498.706285] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9 (usb)
UDEV  [16498.712981] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0 (usb)
UDEV  [16498.716872] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8 (scsi)
UDEV  [16498.722183] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/scsi_host/host8 (scsi_host)
UDEV  [16498.726031] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0 (usb)
UDEV  [16498.729805] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9 (usb)
KERNEL[16499.826883] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0 (scsi)
KERNEL[16499.827443] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0 (scsi)
KERNEL[16499.827805] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/scsi_device/8:0:0:0 (scsi_device)
KERNEL[16499.827897] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/scsi_disk/8:0:0:0 (scsi_disk)
KERNEL[16499.828096] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/bsg/8:0:0:0 (bsg)
UDEV  [16499.830945] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0 (scsi)
UDEV  [16499.834975] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0 (scsi)
UDEV  [16499.840560] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/scsi_device/8:0:0:0 (scsi_device)
UDEV  [16499.844029] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/scsi_disk/8:0:0:0 (scsi_disk)
UDEV  [16499.844428] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/bsg/8:0:0:0 (bsg)
KERNEL[16500.966777] add      /devices/virtual/bdi/8:128 (bdi)
UDEV  [16500.968815] add      /devices/virtual/bdi/8:128 (bdi)
KERNEL[16501.001974] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/block/sdi (block)
KERNEL[16501.009033] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0 (scsi)
UDEV  [16501.132074] add      /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0/block/sdi (block)
UDEV  [16501.138807] bind     /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/host8/target8:0:0/8:0:0:0 (scsi)

That looks normal.

Try

partx -u /dev/sdi

I presume you have already tried rebooting?

partx: /dev/sdi: failed to read partition table

Indeed I have.

I’m not too worried about this for now. I’ll put up with it until another kernel update arrives and see if that fixes it.

Thanks for the advice so far.

Somebody else has reported a similar problem on the Arch forums: https://bbs.archlinux.org/viewtopic.php?id=258991

1 Like

Ah I was waiting for that. The OP pretty much thinks along the same lines as me, same partition numbers listed too.

Also mentioned here @Head_on_a_Stick

Looks like a definite issue with Linux 5.8.8

https://bbs.archlinux.org/viewtopic.php?id=258959

1 Like

Yeah, try the LTS kernel.

2 Likes