Error: archlabs.db download from github failed, resolving timed out

Hello,
When I update keyrings when I try to install ArchLabs, I get a couple of errors.

First:
Error: failed retrieving file ‘archlabs.db’ from github.com : Resolving timed out
I saw in another post from a few years ago that ArchLabs doesn’t use GitHub anymore so I guess I can ignore this error? Or is there a new mirror? What is the new mirror if there is one? I’ve tried searching so if anyone knows that would be a great help. If there is a new mirror for ‘archlabs.db’ do I add it to pacman.conf before install?

Second:
error: failed retrieving file ‘archlabs-keyring-2021.07.11-1-x86_64.pkg.tar.zst’ from bitbucket.org : Maximum file size exceeded

How can I resolve these errors?

Maybe wait a little bit & try updating later on, might be a repo issue that s not updated yet.

You might also have to update your mirrors as well.

1 Like

Found this, hope it can be of any help , it s from @natemaia s post;

I wonder if it s still valid here.

1 Like

They should search the repo (in my other posts url) and get the latest version though. This was some time ago and that download no longer exists

1 Like

Ok ths for the comeback @natemaia

This one @natemaia !

A repo list might also help in here @dayan

Okay, the repositories used in the installer are:
https://github.com/ArchLabs/$repo/raw/master/$arch
https://bitbucket.org/archlabslinux/$repo/raw/master/$arch
archlabs - Browse Files at SourceForge.net

Camera image:


SourceForge and GitHub are both unreachable, I guess because neither are used by ArchLabs anymore?
BitBucket complains that the filesize is too large.

Camera images:


Also, I still haven’t been able to find a mirror for the file “archlabs.db”, does anyone know what it is?

I guess I will try to install ArchLabs when the next ISO releases. I have been trying for a few weeks, but I always get these errors.


Thank you guys for your help.

I had trouble awhile ago with updates and used the below it fixed the .db.

sudo ls -al /usr/bin/checkupdates
password
-rwxr-xr-x 1 root root 3120 1. Jul 01:07 /usr/bin/checkupdates

2 Likes

We’d love to get your system going, it is an extraordinary event. Perhaps a little more info, so we can give it a shot still?
How are you installing: iso from USB or Ventoy?
Install on bare metal or in a VM?
Is it the only OS on this machine or alongside sth else?
Are you selecting specific mirrorcountries? I once had a similar issue but it got resolved by just letting the installer and reflector do its thing, and adjusting it afterwards
What happens when you do the same with, for instance, EndeavourOS?
Any special disk layout you apply?
Thanks, it might give some more clarity for anyone out there trying to help you.

2 Likes

Hello,
I really appreciate your response.

  1. I’m installing from USB. I used BalenaEtcher AppImage to flash my USB key, and I assume it’s flashed in ISO mode and not DD mode.
  2. I’m installing on baremetal. It’s a Dell Latitude E6400. (I chose ArchLabs because of how old the laptop is and how light OpenBox is, I would really like this to work because I need the laptop since I’m moving and need it to write resumes and documents for school.)
  3. It is the only OS on the laptop. I have another partition at the end of the hard drive which is formatted as exFAT which I use as a VeraCrypt partition for important documents. The hard drive is MBR format so there is no boot partition. The BIOS is legacy BIOS only, but the CPU is 64bit (Intel Core 2 Duo p8600).
    Hard drive partition layout:
    dev/sda
    Dev/sda1 ← Bootable root in ext4 format
    Dev/sda2 ← 5GB exFAT partition for VeraCrypt encryption (not currently encrypted)
  1. I live in the USA, so I chose US as my mirror list country, but I’m not having problems with the ArchLinux repository mirrors, I’m having problems with the ArchLabs repository mirrors on the installer. Maybe someone can point me in the right direction to resolve the errors I had with the ArchLabs mirrors I posted in my camera images?
  2. When I tried EndeavourOS, installation went perfect with no errors, but again, I have no issues with the ArchLinux mirrors, only the ArchLabs mirrors.

Thank you again for your help.

2 Likes

KoO,
Thank you, I’ll try your offered solution and see if it works.

You’re welcome. Sounds like a pretty straightforward setup in there, nothing out of the extraordinary afaiac. Let’s see if we receive some more info; we gotta keep you on our team :wink: Thanks for prompt reply anyway!

3 Likes

Apologies for the issues, the sites should be available and we still use both the sourceforge and GitHub for alternative locations for the files so I’m not sure why you’re getting errors but it’s on my radar now and I’d like to help.

Would you be willing to use a testing iso from me? There’s some changes we’ve been working on for a while and it’s nearly ready but still unreleased.

2 Likes

Sure, I’d be happy to test it for you. Let me know.

The latest release of KaOS is out. Always impressed by the quality of his work. Meticulous attention to detail.

1 Like

Looks like a dns issue to me. Are you able to resolve those sites in the installer itself?

Interesting, it looks very nice. I like the grey and blue scheme it comes with. Maybe try it in a VM later this year. My laptop can’t run that though, it doesn’t have an OpenGL cabaple GPU, it’s a very old, very anemic, integrated Intel GPU. Definitely bookmarking it though!

Do you think so? My router is set to 1.1.1.1 and 1.0.0.1 for DNS resolution. As for the installer, that is what I’m trying to do… install ArchLabs. Though, they don’t resolve/work on the installer.