Enable IPv6?


#1

My VPN, PIA has just updated their client which I use when I go to the local coffee shop. It will no longer connect. Their forum says it now uses IPv6 to connect and recommends enabling it for my network adapter. I ran a few checks and I do believe IPv6 is not enabled.

I’m seeing a variety of methods to enable IPv6 with linux via a Duck Duck Go search. My hardware may play into this as well? Anybody have some ArchLabs specific tips, steps to help me figure this out?

(I miss you all. It’s been too long since I’ve been here chatting. I feel guilty for returning for help.)


#2

What s your hardware @sikkdays . Might give a clue.

Please post from terminal;

inxi -N

Edit: Do you use Network Manager ! If so I guess that IPv6 can be enabled from it.


#3

Glad you’re back @sikkdays. Don’t feel guilty, just visit and share. :smiley:


#4

Dagnabit! False alarm. Sorry.

I was prepping for a job interview and decided to run the client update as I studied up. When I got home and installed inxi and poked around, I saw I hadn’t restarted the laptop in 8 days. So, why not. VPN works fine now. :expressionless:


#5

Glad that you got it sorted out !


#6

For future reference, check for IPv6 support with:

empty@shinken:~ $ cat /proc/net/if_inet6                                
00000000000000000000000000000001 01 80 10 80       lo
fe8000000000000038383dfffe39985d 03 40 20 80   wlp2s0
empty@shinken:~ $

Almost all distributions will support IPv6 by default.