Editing /etc/X11/xorg.conf.d/10-monitor.conf minor problem

just installed archlabs on my main laptop the other day and im loving it but in my notes on how to configure xorg and set the primary monitor to hdmi and not putting the saved layout in autostart , i know how to edit xorg with custom resolutions but not with the actual resolution that my computer has which is 1920x1080i and the modeline is different than the ones ive seen…
so i

grep Modeline /var/log/Xorg.0.log
to find the modeline which gave me

"1920x1080i"x60.0 74.25 1920 2008 2052 2200 1080 1084 1094 1125 interlace +hsync +vsync (33.8 kHz eP)

heres my /etc/X11/xorg.conf.d/10-monitor.conf

dentifier “HDMI-1”
Modeline “1920x1080_60.00” 173.00 1920 2048 2248 2576 1080 1083 1088 1120>
Option “PreferredMode” “1920x1080_60.00”
EndSection

Section “Screen”
Identifier “Screen0”
Monitor “HDMI-1”
DefaultDepth 24
SubSection “Display”
Modes “1920x1080_60.00”
EndSubSection
EndSection

can anyone help?should i just put 1920x1080i in preffered mode and modes without the modeline in there or can i put in this which is my openbox autostart and is just my saved layout with arandr

#!/bin/sh
xrandr --output LVDS-1 --off --output VGA-1 --off --output HDMI-1 --primary --mode 1920x1080i --pos 0x0 --rotate normal

Yes, I think so.

The xrandr command should also work but it might be best to put that in ~/.xprofile so that it applies to any and all graphical desktops.

1 Like

… I don’t think xrandr will understand the “i” after 1080. :thinking:

1 Like

yes it didnt understand the i in 1080i if i put in /etc/X11/xorg.conf.d/10-monitor.conf and i also realized 1080i isnt as good for my eyes as 1080 although i can see the difference

thank you guys!!!

quick question how can i disable my laptop monitor and set the hdmi as primary in the /etc/X11/xorg.conf.d/10-monitor.conf

Identifier “HDMI-1”
Option “Primary” “true”
EndSection

Section “Monitor”
Identifier “LVDS-1”
Option “LeftOf” “LVDS-1”
EndSection

do i put disable or something in where is says left off

solved with

Section “Monitor”
Identifier “laptop panel”
Option “ignore” “true”
EndSection
Section “Monitor”
Identifier “big display”
Option “Primary” “true”
Option “PreferredMode” “1920x1080”
EndSection
Section “Device”
Identifier “onboard”
Option “Monitor-LVDS-1” “laptop panel”
Option “Monitor-HDMI-1” “big display”
EndSection