Dwm troubles

#1

I can’t find how to reconfigure the dwm that comes with archlabs.

0 Likes

#2

@gorry You have to recompile dwm. Type in your terminal "cd ~/suckless/dwm -> Than push Enter/ ls -> Enter/ make -> Enter/ sudo make install and than push this buttons alt + shift +q (logout/login)

and or read this: https://wiki.archlinux.org/index.php/dwm
https://suckless.org/hacking/
https://dwm.suckless.org/

2 Likes

#3

Ha, im not surprised. Suckless are known for having very little documentation. What are you trying to configure?

0 Likes

#4

That’s by design:

:grin:

They do have a brief HowTo though:

https://dwm.suckless.org/customisation/

And there is a nice guide over at the Debian forums:

http://forums.debian.net/viewtopic.php?t=65110

^ Use the “quick-and-dirty” installation method to copy the dwm binary the /usr/local/bin, this will be preferred over /usr/bin/dwm (which I think is used by the ArchLabs package) but then pacman will be unaware of it’s existence.

There is a dwm-git AUR package that will copy a custom config.h over and compile it into an Arch package, just remove the two $pkgname/ instances in prepare() to get it to work properly (as per the last comment on the package page).

I have no idea how the ArchLabs version works though, it doesn’t seem to be in the bitbucket repositories.

1 Like

#5

@Head_on_a_Stick thats what catches newbies out with dwm, the documentation paradox. Most people not well versed will just say this suckless stuff is broke :wink:

Also if you are going to use suckless software i believe its better to install it from the source not have it packaged up by archlinux or debian, not saying its not a valid option it is when packaged to your liking but 99 percent of the time you will need to figure out patching if you want more configuration.

0 Likes

#6

The first answer helped me, it worked. In my humble opinion it makes no sense to install it from source. The project in development?

1 Like

#7

The program can only be configured by changing the source code and then recompiling so you don’t really have any other option.

I’ve given up packaging it at all, I just don’t think it’s worth the bother because it’s only a single binary (and a useless man page).

The program is still under development but it doesn’t change much, v6.2 was released last month so it should stay fairly static for a while now.

The next release will drop Xft support, apparently, so I’ll have to patch that back in.

1 Like

#8

I replaced in the dwm 6.2 folder two of my customized and patched config.h and dwm.c files from the dwm 6.1 version, and then installed the app. After installation shows version 6.2, also all my customization was applied. Is this installation method correct? I tried to install as you advised but for some reason nothing came of it.

0 Likes