DWM malfunctioning

Please see the screenshot, I think that explains.

So yesterday I noticed that dwm was not functioning properly. As you can see, it is not putting the window on the entire space, though it is in tiling mode =[]. Also, if I change to tag 3 (say), it still shows tag 1 in the bar, though it does indeed go to tag 3. Finally, if I open firefox (say) from the terminal I have scrotted, it will open it on top of the terminal, and occupying about 2/3 of the desk.

I reinstalled dwm just now, but the problem is exactly as described. I did not rebuild it, I will do that shortly, but thought to get inputs from folks if they have seen this issue.

–Protect teachers, for God’s sake. Don’t let there be another Samuel Paty.

UPDATE: OK, so I figured out the problem.

I have 2 monitors connected.

  1. If dwm is run w/ both monitors separate (ie, not mirror) then things work fine, and as expected.
  2. If after logging in, I use xrandr to mirror the monitors (which I need to do for some applications), then the problems arise. I am able to reproduce.

@natemaia: I strongly suspect the issues I was having w/ yax are some other form of this. Namely, multimonitor setup, and some xrandr commands do unexpected things (at least to dwm, and I would say probably to yax). That is also likely why only I experienced these things—multimonitor + xrandr configs are not usually common to many users (meaning, even if lot of multimonitor folks tested yax, likely none of them had my xrandr configs). Please look into this, would love be able to re-test yax after that is fixed.

I don’t see where this relates to yax, if you check the process tree and it isn’t running then it’s not the issue.

Just a quick note, if a monitor is a mirror of another then it isn’t even considered as another monitor in most wm including yax and they just let X do what it wants with it; meaning it’s only changed through connect/disconnect, xorg configs, and xrandr commands.

You should really post the relevant configs (xinitrc, xrandr commands, xprofile, etc.) then there would be more help and useful information people could provide, otherwise it’s all just guess work.

You appear to have two issues -

If you disable the LightDM service, reboot, and log into dwm with startx, do you still have these issues?

You should really post the relevant configs (xinitrc, xrandr commands, xprofile, etc.)

Good idea, I will do that. I will try to post those tomorrow.

I also don’t see the relation to yax. But then I did not see the relation of this to dwm. Something is wrong, hopefully the files will help isolate.

@PackRat

My initial tests w/ dwm were as you describe (ie w/ startx) and the monitor/tag hopping was consistently present. That is why I think the lightdm issue is a separate one since the yax issue happened even when lightdm was bypassed. Not only that, I even moved to GDM for testing yax precisely to preclude the possibility of lightdm messing things up, andthe hopping happened even then. After seeing dwm messed up w/ xrandr, I am thinking this issue is deeper than at least my knowledge can analyze. I’ll post files, and test more.

AM posting the files (why leave for tomorrow what you can do today, especially at my age he he he).


└> % cat .xprofile
#!/bin/sh

# ~/.xprofile

# sourced at boot by ~/.xinitrc and display managers like lightdm

export XDG_CONFIG_HOME="$HOME/.config"

[ -d /sbin ] && PATH="$PATH:/sbin"
[ -d /usr/sbin ] && PATH="$PATH:/usr/sbin"
[ -d "$HOME/bin" ] && PATH="$HOME/bin:$PATH"

# restore the background
# nitrogen --restore &

# keyring and polkit daemons
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
gnome-keyring-daemon --start --components=pkcs11 &

# WAS:super alone simulates Alt-F1
# NOW: super is Alt-p for dmenu_run
ksuperkey -e 'Super_L=Alt_L|p' &
#ksuperkey -e 'Super_R=Alt_L|F1' &

# dpms: timeout sleep off
xset dpms 600 900 1200

# keyboard repeat rate
xset r rate 350 60

# set up clock on dwm
while true
do
xsetroot -name "$(date)"
sleep 10
done &

# set up my dual monitors and put wallpaper on them
# both-horizontal-setup

# start xfce4 power manager to suspend when idle etc.
# xfce4-power-manager

.xinitrc is currently not present. When I tested yax, it had just the line exec yaxwm. The current issues w/ dwm can be reproduced w/ .xinitrc absent (that is why I removed it, for testing).

What else? Yes, right, the xrandr configs. here they are:
I have several such configs, and I issue the command either in .xprofile (as you can see, it is currently commented out for todays tests) or at the terminal. Here are 2, the rest are very similar, I can post all if you like, but I can repro the issues w/ these two itself.

┌ ~/bin
└> % cat both-horizontal-setup                                                                                                        19:24:28
xrandr --output HDMI1 --auto --right-of LVDS1
xrandr --output LVDS1 --rotate normal
xrandr --output HDMI1 --rotate normal
feh --bg-max --auto-rotate --randomize $HOME/Pictures/* $HOME/Pictures/*
┌ ~/bin
└> % cat mirror-horizontal-setup                                                                                                      19:24:33
xrandr --output HDMI1 --auto --same-as LVDS1
xrandr --output LVDS1 --rotate normal
xrandr --output HDMI1 --rotate normal
feh --bg-max --auto-rotate --randomize $HOME/Pictures/*

Let me know if you need anything.

“Samuel Paty lives on. I am Samuel Paty.”