Drun (rofi) menu has wrong keyboard layout

#1

Hi guys, I noticed that my drun (rofi) menu has not my system wide keyboard layout. my system wide keyboard layout is de-latin1-nodeadkeys but when I hit Win-Key and type a “z” on my keyboard a “y” is displayed.

so it seems that drun(rofi) uses it’s own layout but I can not find the config where I can specifiy this. anyone an idea how to fix this? :slight_smile:

0 Likes

#2

I fixed it a minute ago by typing setxkbmap fr (as I am french) in the terminal

might want to store that in xinitrc to make sure it is set at boot…

Edit: seems to be working better via the keyboard manager by unsetting the default keyboard settings and setting

0 Likes

Rofi doesn't consider keyboard config
#3

i have the same problem. typing “setxkbmap de” in terminal fixes it until reboot.
how do i set this permanently?

1 Like

#4

Add “setxkbmap de” in your .xprofile.
Now it is permanent.

1 Like