Doesn’t boot after fresh install

@DanGrv what @anon52460207 said! :smiley:

I got the same problem as DanGrv so I followed your instructions. Everything goes correctly execpt in this commands pacman -Syyu mkinitcpio -p linux and grub-mkconfig -o /boot/grub/grub.cfg. I’m new to this so I have no idea how to troubleshoot this, please help. Oh also idk if it matters but I have my os on sdb(I put sdb in commands instead of sda) which is a ssd and when rebooting unmount fails.


I’m a new user so I can’t post more screenshoots

Sorry if I’m a idiot

@natemaia, any ideas here?

Ignore me, didn’t read properly.

Huh so guess im not the only one, currently at the airport but i’ll make sure to run the commands tomorrow! I’ll keep everyone posted

Might be something up with the master key?

https://bbs.archlinux.org/viewtopic.php?id=233480

delete & repopulate?

Yeah re-do your GPG and see how it goes.

forgot to mansion that I have a amd cpu x1800 to be specific and heres another screenshot

Without performing the update your systems will continue to be broken.

The conflicting package that seems to be causing issue: python-regex, should be removed.

Try

pacman -Rns aurman python-regex python-dateutil

Before running the update.

You can also do

pacman -Scc

to clear your package cache but this isn’t needed once they’re removed. Once done run the update again pacman -Syyu

2 Likes

I Do these 2 last commands (from the above post) every times I m on my AL install, works wonders @natemaia

I’ve done what you said but I still get the errors, for pacman -Rns aurman python-regex python-dateutil I get targets not found for aurman and python-date. After that I get the same errors any ideas.

no good I get error: failed to prepare transaction (could not satisfy dependencies). Also I think its the some error but it says python-regex is unknown trust when trying to download packages.

I’m just thinking of a possible thing that I did wrong, one thing that I can think of is updating the os before installing but idk if that possible.

Don’t worry we will have a new version out soon.

1 Like

Hi,
I’m new to the forum and I’m having the exact same problem. I installed Arch-labs a few days ago and everything went smoothly; them I spent some time doing some ricing and yesterday I wanted to start again from a plain install and I experience the same issue. I also tried to recover using the live system and chroot but the problem still persists. I confirm the problem is with python-regex and the signature key.

Any idea how to workaround without waiting for a new live image?

Thanks

Thanks @anon52460207, I will wait for the new iso. For the moment I’m using Manjaro, but I want to reinstall Archlabs.

1 Like

@Dobbie03 @anon52460207 @natemaia Thank you guys and the entire Arch Labs team, the new 18.12 update fixed all the issue I’ve been having! Absolute legends :muscle:

5 Likes

Just gonna add a little edit to your post. You forgot to mention someone very important who is the backbone behind this update :smiley: Nate!

Hope you don’t mind!

2 Likes

A complete newbie here, a question if I may piggy ride on this thread as I am also encountering this issue of reinstalling (currently d/ling the latest 12/18 iso).

As I read from Arch wikis and tutorials, I understand it requires 4 partitions: Boot / Swap / Root / Home.

However, from my ArchLabs installation, it only asked for which partition should the OS be installed on and that is it. Thus, my question is, when you said sudo mount root (sda2) and boot (sda1) … what should I do? All my installation is in one partition sda4.

In most cases, root would be the part that would hold the OS. And in most cases, boot would be the smaller/est part.

Have a look at this thread : ArchLabs on YouTube
You may find the vis interesting and probably answer some of the questions you may have after the fact.

Welcome and happy Labing!

Just using the tick box. Shows in the thread list.

1 Like