Display not working as I want it to


#1

Hello, I just made a fresh install because I got curious about what’s new. :slight_smile:
I thought I had mixed up some things in my last setup and was too lazy to fix them yet, but no better time to do that than with a fresh install, right?
Here’s how it was:
Whenever I tried to deactivate conkys or didn’t move the nitrogen restore in the right place in autostart, my background got all mixed up and I had to set them again everytime I boot the system up. Also everything above a given line wouldn’t always work. For instance, whenever I rightclicked on my desktop for the openbox menu to appear while my cursor was ‘north’ of the line, it would still appear, but beneath the line I’m talking about. Geany, sublime and whatnot was the same, I could use the menu when in maximized window even when they were ‘north’ of the line, but the menu itself would open beneath the line.
Now I have a similar problem: whenever I use nitrogen, my backgrounds get all mixed up, so I tried to use feh and that works. I still have the problem with the ‘line’ I’m constantly talking about though. When I have certain programs running, sometimes the menus work, sometimes they show the behaviour from before and open beneath the line (ofc I cannot get any programs to act like that right now to screenshot it), some programs I can only move up to this line and not further, some programs work fine beneathe the line, but as soon as I move them north of it, everything above the line cannot be interacted with via mouse anymore.
It’s not all programs though. termite for instance works wherever it is, Unreal Engine does not.

I made a couple of screenshots, because I think they might explain better what I’m trying to say here.
The first one is with feh and shows my setup how it’s supposed to be looking - more or less, I don’t really need the spaces above the left and right screen, but it also doesn’t hurt:

when I have nitrogen loading my backgrounds the following is happening - in red are my screens and what’s actually showing:

and here to show what I mean with the mysterious line, you cannot see my cursor for some reason, but in both cases it’s hovering the ‘maximize button’ (marked the area with the red circles), when the window is below the line, you can see it having an impact because the hovering action appears, when it’s above - no hovering action and I cannot click it or use menus, or whatever’s above the line.

I didn’t do anything with conf files regarding the xserver, i think. I did run ARandR though and saved my layout and I’m loading it in autostart.
I tried to read about randr and xorg and whatnot here but I’m not getting anywhere. Mostly bc of a lack of understanding on my side.

What I’d like to have is that I can access the parts above this mysterious line on my main screen whenever and with whatever, I want to be able to move things around all three screens (that works) and if possible I’d like to be able to adress different screens individually. Not sure if that would work though, but I’d like to start my browser on the left handed screen, some wine apps on my right, most on my middle screen, etc.

If I get it right, I have all screens summed up in one display, what’s leading to the 6400 x 1440 display, with:
1920x1080 + 2560x1440 + 1920x1080 screens, hence the white or black spaces (no idea why they change colour…).

I tried to be as specific as I can right now, so just ask for whatever I missed out on or you don’t understand, no native speaker, that probably complicates matters even further.

Thanks in advance for any help!


#2

Well I don’t have an exact solution for your problem, what I do have is an xorg config that I use to fix a similar issue of mine

I use 2 x 1920x1080 screens with one in portrait orientation and it causes some of the issues your talking about.

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "DP-1: 1920x1080_120 +1080+420, DVI-D-0: 1920x1080_120 @1080x1920 +0+0 {rotation=left}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

The ‘metamodes’ line is all we really care about in this case, just ignore all the specifics and nvidia… Format is in

display: resolution_framerate @viewout +offsetX+offsetY {options}, ...

I had similar issues where the scaling was all messed up and clicking in places wouldn’t work properly or at all, all the GUI stuff I tried was god awful and wouldn’t just let me edit the field values. You just need to do the simple math, figure out the offsets for each screen and just configure them this way.

What you likely want is to have the giant screen (6000x1440) with the 1440p monitor setup just normally at a +1920+0 offset (centred).

Then you want the 2 x 1080p screens configured to +0+360 and +4480+360 offsets respectively however I believe with these you’ll want to set the view out to be 1920x1080 like so @1920x1080

Not ideal but it’s what I got to work for me.

Cheers


#3

Thanks for your reply, i tinkered around a bit and tried various things, nothing has worked out so far though.
With the nvidia-settings I got a pretty similar output for my xorg.conf, tried this one, your one with adapted values - there’s still that odd behaviour.
I only had one of my monitors under Section “Monitor” though and added the other two now. It still doesn’t work, so maybe I messed up something in my xorg.conf by now, here’s what it looks like (I cut the Input Devices and Files section):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Monitor"
  Identifier "DP-0"
  Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
  VendorName    "AOC"
  Option "PreferredMode" "2560x1440_60.00"
  Option  "Position" "1920 0"
  Option "DPMS" "true"
EndSection

Section "Monitor"
  Identifier     "DVI-I-1"
  Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
  VendorName     "BenQ"
  ModelName      "BenQ V2420"
  HorizSync       30.0 - 83.0
  VertRefresh     50.0 - 76.0
  Option  "PreferredMode" "1920x1080_60.00"
  Option  "Position"  "4480 360"
  Option         "DPMS"
EndSection

Section "Monitor"
  Identifier "HDMI-0"
  Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
  VendorName     "Samsung"
  Option  "PreferredMode" "1920x1080_60.00"
  Option  "Position" "0 360"
  Option  "DPMS" "true"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "DP-0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DVI-I-1: 1920x1080_60 @1920x1080 +4480+360, HDMI-0: 1920x1080_60 @1920x1080 +0+360, DP-0: 2560x1440_60 @2560x1440 +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
        Virtual 6400 1440
    EndSubSection
EndSection

#4

Yea the monitor sections actually don’t really matter, I try to avoid configuring things that will otherwise be automatically set up just fine (monitors, keyboard, mouse, etc) The main section you need to man handle is the “Screen”.

What you have there looks like it should be ok, one thing I would try is dropping the @2560x1440 for the primary monitor, it shouldn’t need it. Also try dropping the Virtual 6400 1440 bit out of the inner “Display” subsection. One last thing I notice is you don’t have any of the monitors include in the screen section, try defining them as “Monitor0, Monitor1, …” then include them in the screen like mine above, or just removve them and see how it goes.

Once you do get it sorted you’ll likely also want to enable the “ForceFullCompositionPipeline” options.


#5

when i leave the monitor section as per nvidia-settings xorg.conf, there’s only one entry for my DVI monitor under Section “Monitor”, the one to my right, with 1920x1080 connected via DVI-I.

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ V2420"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

When I activate ForceFullCompositionPipeline options (I just had to try…), I can login after booting, but the next thing I see is all grey and my mouse cursor. that’s pretty much it. :slight_smile:
Tried both just deleting the xorg.conf and removing the ForceFullCompositionPipeline options. Both cases work as it’s always been, I get them (the screens) in the right order, I have trouble on my mainscreen as soon as I enter the upper area.
Another thing that’s odd: when I delete my /etc/X11/xorg.conf file, my lightdm adresses the DVI monitor on my right, active-monitor is set to 0. In this case I have to set it to 2 to adress my middle monitor connected via DP-0, leaving active monitor 1 for my hdmi on my left side.
When I have the above xorg.conf it shows lightdm on my middle screen with activemonitor set to 0 and my hdmi screen on my left, when set to activemonitor 2. leaving my DVI monitor with 1.

The middle monitor is set to primary in every place I’ve found so far, but still the only one in xorg.conf is the DVI monitor, right? So maybe that’s the issue, that the smaller monitor is limiting some things to it’s native resolution?
I might as well just ignore it though. It’s more of an inconvenience and right now I just get more and more confused.


#6

Are you running xrandr commands somewhere in your startup or just the above config?

The two probably conflict or at the very least override each other, before using xorg configs I had tried to use some programs like xrandr, and other screen settings display setters, I’m not sure how/where/why but they must create a config, half of my monitor would be completely unusable on boot and I would have to run xrandr commands or nvidia-settings to reset it each boot :expressionless:


#7

I don’t think this is a problem, mine is the same yet I have no issues with the “wrong monitor” being the only one configured


#8

Ah, yes, I do run a randr script. Totally forgot about that, I’ll comment it out and try things again without it. thanks for pointing that out.


#9

Sweet, I’m also gonna do a quick test to see if we even need the monitor sections at all.


#10

Ok, just did a quick reboot and I can confirm 90% of the stuff nvidia-settings adds to the xorg config is completely not needed, here’s my whole /etc/X11/xorg.conf.d/20-nvidia.conf

# nvidia xorg screen configuration file

Section "Screen"
    Identifier     "Screen0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "DP-1: 1920x1080_120 +1080+420 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DVI-D-0: 1920x1080_120 @1080x1920 +0+0 {rotation=left, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I had no problems after a reboot, same setup


#11

You shouldn’t need it in most cases, if I got it right, but if auto doesn’t work you need to get more specific. With a 120 hertz monitor I assume you got more than just the usual ‘whatevs, it’s a monitor’ devices I got here.
I thought my left screen to be broken anyways. I cannot see the archlabs logo on that screen, it’s just one color. the top bar is just black. That’s why I tried to get the monitors in there to see if there might just something be wrong with adressing them or however it works.
Here’s what happened: with a basic or without xorg.conf, like the one you posted but without Forcecomposition, it’s still the same.
With Forcecomp activated it’s still a gray screen after lightdm.
With an extended xorg.conf like the one I had posted earlier, I got a SEV: failed to get status error while booting. Google says that might be a problem with my bios version. So I flashed my BIOS. While doing that and considering broken hardware as a problem, I just booted into windows (I honestly forgot about it, haven’t booted it for quite some time…) and here (still in windows right now) everything works fine. there’s no difference in colours between the left screen (which I thought to be broken) and the middle screen, just a minor difference between the right and the other two (the right one works fine in Linux though, the left one is the one with the all broken colours), but you really have to look closely. Under Linux it’s impossible to not notice.
I’ll reboot again and see if the bios updated has changed anything.

Update:


That’s not edited, that’s what I’m looking at right now. That’s my (I guess the standard?) windows background there…


#12

Yikes.

So is your mouse confined to the right location and the only issue being the wallpaper?

Also worth pointing out that the composition pipeline settings shouldn’t affect anything but vertical sync to reduce screen tearing.


#13

You definitely have multiple settings conflicting there, the bit on the bottom is where the pixels have never been updated.

I’m running out of solutions for you however I know that your setup is not super complex, running xinit with a basic xorg config and nothing else I could have your monitors working.

What does your Xorg log look like, anything of note regarding updating settings twice?

less /var/log/Xorg.0.log

What is your current output setup

nvidia-settings -q CurrentMetaMode

I’m wondering if it’s lightdm causing the issue, can you try

rm -rf /etc/lightdm

# this will reinstall fresh clean configs under /etc/lightdm
pacman -S lightdm lightdm-gtk-greeter

#14

My mouse actions are partly confined to the area +6400 +360 - everything above +360 might or might not be confined. termite works fine for instance, unreal engine does not, firefox is delivering mixed results. the titlebar for firefox is the standard bar, like termite has, styled by my theme. that one works. notifications are moved beneath the +360 line though (in some cases, not all. for FF they’re moved).


UE doesn’t use the system style titlebar but comes with it’s own and I cannot access the menus as soon as they’re located above the +360 line. When I move them below it I can access them again.
Some wine programs start at +0 +0 for instance, so basically off of my actual screen, if programs open on my main screen they are centered in the lower part, acting as it were a 2560x1080 or 1920x1080 screen
The all-messed-up-screenshot comes from booting without a randr script or an xorg.conf, what he does from my understanding is using the standard order of screens to make a big screen:
starting from 0 0 -> DVI +0 +0 -> HDMI +1920 +0 -> DP +3840 +0
and then ordering my monitors the way I actually want them to be with(again from 0 0):
HDMI +0 +360 -> DP +1920 +0 -> DVI +4480 +360.

With either the following randr script:

xrandr --output DP-3 --off --output DVI-I-0 --off --output HDMI-0 --mode 1920x1080 --pos 0x360 --rotate normal --output DP-5 --off --output DP-4 --off --output DVI-I-1 --mode 1920x1080 --pos 4480x360 --rotate normal --output DP-2 --off --output DP-1 --off --output DP-0 --primary --mode 2560x1440 --pos 1920x0 --rotate normal

or an xorg.conf I can get the desired results for my monitorlayout and the screen, but I run into the said trouble with some things showing in the wrong places or things not being clickable.

I have the following files in the following directories:
/etc/X11/

  • /xorg.conf.d/
    • 00-keyboard.conf
    • 40-touchpad.conf
  • xorg.conf

/usr/share/X11/xorg.conf.d/

  • 10-amdgpu.conf
  • 10-edev.conf
  • 10-nvidia-drm-outputclass.conf
  • 10-quirks.conf
  • 10-radeon.conf
  • 40-libinput.conf
  • 50-vmmouse.conf
  • 70-synaptics.conf

So there shouldn’t be any multiple files doing different things from that side, xorg.conf is the only place I’m playing around with screens, monitors and whatnot. might still be that randr and xorg are getting in each others way though.

xorg.conf right now, used for booting:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 415.25

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
  Identifier "DP"
  Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
  VendorName    "AOC"
  Option "PreferredMode" "2560x1440"
  Option  "Position" "1920 0"
  Option "DPMS" "true"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "DVI"
    Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    VendorName     "BenQ"
    ModelName      "BenQ V2420"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option  "PreferredMode" "1920x1080"
    Option  "Position"  "4480 360"
    Option         "DPMS"
EndSection

Section "Monitor"
  Identifier "HDMI"
  Modeline "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
  VendorName     "Samsung"
  Option  "PreferredMode" "1920x1080"
  Option  "Position" "0 360"
  Option  "DPMS" "true"
EndSection

Section "Device"
    Identifier     "Device0"
    Option         "Monitor-DP-0" "DP"
    Option         "Monitor-DVI-I-1" "DVI"
    Option         "Monitor-HDMI-0" "HDMI"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "DP"
    Monitor        "DVI"
    Monitor        "HDMI"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DVI-I-1: 1920x1080 @1920x1080 +4480+360, HDMI-0: 1920x1080 @1920x1080 +0+360, DP-0: 2560x1440 +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

nvidia-settings -q CurrentMetaMode:

Attribute ‘CurrentMetaMode’ (staeffn:0.0): id=50, switchable=yes, source=RandR :: DPY-1: 1920x1080 @1920x1080 +4480+360 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0},
DPY-2: 1920x1080 @1920x1080 +0+360 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DPY-3: 2560x1440_75 @2560x1440 +1920+0 {ViewPortIn=2560x1440,
ViewPortOut=2560x1440+0+0}

The Xorg.0.log output is very long, so I used some external site:
https://codeshare.io/5OXMb0

I’m also trying to get formatting right.

removed and reinstalled lightdm: no changes.

The german ubuntu wiki says that nvidia cards have some problems with randr and that you use nvidia-settings for stuff like that. Doing that. But it also says that nvidia-settings deactivates randr entirely. If I get nvidia-settings -q CurrentMetaMode right, I’m still using randr though, right?

edit #2392: There’s definetly something wrong with my monitors. I’ll try to make a photo that demonstrates it, but it will take some time.

That’s a screenshot from my screen showing on my left monitor, under arch and under win10, so same thing showing on the same physical device just under 2 different OSses(? no idea what the plural is :)):


#15

Correct, randr or Rotate and Resize is the Xorg interface that allows changing and configuring displays and Xscreens on the fly, before this we had a number of other more hacky solutions like Xinerama, multi-head, etc.

I still think trying to bind multiple monitors to the Screen0 is not actually doing anything and just doesn’t matter, checking the log you can see

    [     7.511] (==) Using config file: "/etc/X11/xorg.conf"
    [     7.511] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [     7.511] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [     7.513] (==) ServerLayout "Layout0"
    [     7.513] (**) |-->Screen "Screen0" (0)
    [     7.513] (**) |   |-->Monitor "HDMI"
    [     7.514] (**) |   |-->Device "Device0"
    [     7.514] (**) |-->Input Device "Keyboard0"
    [     7.514] (**) |-->Input Device "Mouse0"
    [     7.514] (**) Option "Xinerama" "0"
    [     7.514] (==) Automatically adding devices
    [     7.514] (==) Automatically enabling devices
    [     7.514] (==) Automatically adding GPU devices
    [     7.514] (==) Automatically binding GPU devices
    ...
    ...
    [     8.681] (II) NVIDIA(0): Setting mode "DVI-I-1:1920x1080@1920x1080+4480+360,HDMI-0:1920x1080@1920x1080+0+360,DP-0:2560x1440+1920+0"

Also just looking at the output from your nvidia-settings

DPY-1: 1920x1080 @1920x1080 +4480+360 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0},
DPY-2: 1920x1080 @1920x1080 +0+360 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0},
DPY-3: 2560x1440_75 @2560x1440 +1920+0 {ViewPortIn=2560x1440, ViewPortOut=2560x1440+0+0}

It seems like the viewportout isn’t matching up with the location of the screen, perhaps instead or along with the @...x... you should define the ViewPortOut=... to match the screen offset eg.

Option "metamodes" "DVI-I-1: 1920x1080 +4480+360 {ViewPortOut=1920x1080+4480+360}, ...."

# or maybe just simplifying it
Option "metamodes" "DVI-I-1: 1920x1080 +4480+360, ...."

Without doing any changes, but set up your screens using nvidia-settings, what does the xorg config it generates look like?

There is also a lot of information here where options and examples for configuring multiple monitors on on Xscreen
https://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html

Plural for OS in english would indeed be OSes :slight_smile:


#16

Sorry, christmas, took me a while. That’s what my nvidia-settings is creating:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 415.25

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ V2420"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +4480+360, HDMI-0: nvidia-auto-select +0+360, DP-0: 2560x1440_75 +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

My 960 is having trouble with my newish monitor and games though, so I’m thinking about getting a new GPU anyways. Maybe I’ll just grab a Vega and try my luck with AMD instead of nvidia. :slight_smile:


#17

I’m back - different drivers, different GPU - same problem. I don’t have Unreal Engine installed right now, but who needs big programs if you can achieve roughly the same with thunar and firefox? :slight_smile:
Actually that’s not entirely true, firefox works for the better part. When I open the menu, it’s in the right place,when I right-click it’s in the rights place, notifications while in fullscreen are below the line, sometimes they ‘hop’ into the right place though when I go back to windowed mode, sometimes they don’t and I have to move the window around a bit and that might work. Thunar on the other hand - the menu in the header part and the right click menu will always open below the line. (cannot take screenshots right now, results in a bunch of error messages, so I have to describe it as best I could).
Here’s what just happened: I tinker around a bit with oomox and when I switched to my freshly created gtk, this happened:


That I’m not able to make a decent gtk (yet) isn’t what got me thinking, that I get a bunch of windows with different styles on the other hand, especially those making problems…

Maybe it’s the same as with geany. I don’t have geany, still I get error messages that geany cannot be opened, some files try to load in geany (that’s my guess at least) and I don’t even know why or what file might do that, bc I already switched everything to atom I could possibly find.
Dunno if that makes sense, what I’m trying to say/ask - is there anything obvious that might be the root of my problem, that might narrow down what I have to look for or that maybe tries to access config files/whatever and breaks my desktop that way?

Edit#1: Seems like it’s a problem with polybar. I set up archlinux again and tried to rebuild archlabs, if that makes sense, so that I can see when and where problems occur. As soon as I load my polybars into the mix, the odd behaviour starts. Will investigate further.

Edit#2: As soon as I load up polybar on one of the smaller screens (tested with empty polybars with just a line of text), it breaks the screens. If I only load up polybar on the bigger screen it works.