[Display Manager] What's the default?

Hi all!

I’m new here so I hope “Basic Help & Support” is the right section for my question (I’ve looked and found nothing).

As a far-from-expert Linux user but an Arch fan I’m always looking for the best way to get it into my computer.
Trying ArchLabs Linux and upon customization I tried to change the display manager but I couldn’t get LightDM to run. It always automatically logs in bypassing DM all along.
I figure I’d have to disable the active one… I just don’t know witch one is it.

Any help, please?
(and sorry if I’m missing something very basic)

Thanks and keep up the great work!

If I understand this correctly, lightdm is indeed running and automatically logging in the user associated to you. I think you left “automatically log in” option checked during installation. However if you want to change it, edit the the file /etc/lightdm/lightdm.conf and comment the line containing autologin-user=.

1 Like

Actually I don’t know I it’s running automatically or not.
In the config menu it’s not setup as auto login in any user.
How is ArchLabs Linux setup as default? I’ve noticed that it logs in automatically.

Don’t forget to remove the affected user from the autologin group… This step is important, if you want to completely disable the automatic login.

 gpasswd -d user autologin

Log out and log back in for the group changes to take effect.

4 Likes

The default for ArchLabs is to use LightDM and autologin.

I do what pangolin suggested to stop autologin.

What AvnSgt pointed out is news to me, so thanks for that!

1 Like

Thanks guys!
When I read the first reply I thought about that group thing. Guess I’m starting to get smart. (:

Thanks guys!!

1 Like

@joaojotta I am glad that @AvnSgt and @pangolin as able to help you. If you would be so kind as to mark this as solved so that when someone else has this problem, they would know to come here for the solution. Thank you.

1 Like

Good Day!
When you want to see what services are running, you could always execute the following command in a terminal

systemctl

There you should see the lightdm.service running, as you scroll down :slight_smile:

3 Likes

@pangolin I have an apology to make, you also helped in solving this issue and I have edited my reply accordingly.

1 Like

ayy cheers mate…didn’t think much of it anyway!

2 Likes

@anon39737049 -

systemctl | grep running

should shorten your list - I usually have a bunch of bash/zsh aliases for that sort of thing.

3 Likes

Darn, I’m loving where this topic is going! (:

THANKS!

2 Likes

Awesome! This is a neat command!

Looks like systemctl has been revised so grep is no longer needed

systemctl --state=running

appears to work as well.